Welcome to our peer-to-peer forums, where owners help owners. Need help now? Visit eSupport here.

English Community

Lenovo NotebooksLenovo P, Y and Z series Notebooks
All Forum Topics
Options

8 Posts

03-06-2014

26 Signins

130 Page Views

  • Posts: 8
  • Registered: ‎03-06-2014
  • Location:
  • Views: 130
  • Message 1 of 419

Re: Lenovo Z510 CPU stuck at 0.77GHz

2014-03-06, 18:40 PM

EDIT NOTE : This post was move to the top of the page to assist Lenovo with an escalation. For all future post and comments, please continue posting in this thread.

 

i have this issue too, but when i changed the option "intel virtual technology" to enabled in the bios configuration section, my laptop started at 3.2 ghz on battery, then i changed the power option from "high performance" to "power saving" mode, it was redused to 0.77, then i changed back to performance mode,it speeded up till max. it seamed problem was solved. 

 

i am not sure what intel virtual technology is doing or related to this issue, but it's worked for me. i hope this helps.

 

meh, after 3 restarts it's stuck at 0.77 again, i think we definetly need a bios update.

 

Edit- After a quick search, i ve found that "intel virtual technology" doesn't related to this issue, and it' NOT THE SOLUTION.  problem still exists.

 

Also, just fyi, some other brands of devices faced this issue over the inernet and all solved by bios update or board replacement. 

 

 

 EDIT NOTE : This post was move to the top of the page to assist Lenovo with an escalation. For all future post and comments, please continue posting in this thread.

 

 

Reply
Answer
Options

1609 Posts

09-16-2014

United States of America

3048 Signins

61403 Page Views

  • Posts: 1609
  • Registered: ‎09-16-2014
  • Location: United States of America
  • Views: 61403

Re: Lenovo Z510 CPU stuck at 0.77GHz

2014-12-02, 1:23 AM

Just a note - BIOS v40 was officially released on 11/25 and can be found here: http://support.lenovo.com/us/en/products/laptops-and-netbooks/ideapad-z-series-laptops/ideapad-z510-notebook

 

Thanks to everyone who participated in the discussion and troubleshooting of the reports of the CPU becoming stuck at 0.77GHz. I appreciated your input and assistance.

 

Thank you,

Reply

Replies(418)
Options

50 Posts

01-30-2014

Hungary

53 Signins

710 Page Views

  • Posts: 50
  • Registered: ‎01-30-2014
  • Location: Hungary
  • Views: 710
  • Message 2 of 419

Lenovo Z510 CPU stuck at 0.77GHz

2014-01-30, 15:54 PM

Hi!

 

The CPU (i3-4000M) in my Z510 sometimes stuck at 0.77GHz. It doesn't matter if I set the performance to maximum in Windows and in Lenovo Energy Manager.

 

It usually happens when the notebook is unplugged from AC but sometimes it happens on AC too. And also it doesn't matter if the computer is cold booted, restarted or waked up from sleep\hibernation.

 

I have read about a lot of similar cases (just google on "stuck 0.77GHz").

I'm using Windows 8.1 x64, the drivers ar up-to-date and all of the updates are installed.

 

We are talking about a wold-wide problem since it is exists in other notebooks too. (e.g.: Asus)

 

Is there any (un)known problem with the new Haswell processors\chipsets?

What is the solution?

 

Reply
Options

7 Posts

12-21-2013

Hungary

10 Signins

67 Page Views

  • Posts: 7
  • Registered: ‎12-21-2013
  • Location: Hungary
  • Views: 67
  • Message 3 of 419

Re: Lenovo Z510 CPU stuck at 0.77GHz

2014-01-31, 21:08 PM

Same experience here with i5-4200M and Win7.

I am really getting fed up with Lenovo Z510.

Reply
Options

50 Posts

01-30-2014

Hungary

53 Signins

710 Page Views

  • Posts: 50
  • Registered: ‎01-30-2014
  • Location: Hungary
  • Views: 710
  • Message 4 of 419

Re: Lenovo Z510 CPU stuck at 0.77GHz

2014-02-08, 9:52 AM

Lenovo please, do something with this problem.

 

On the support page of Z510 it says "Bios update is not required for this product", but it's not true.

The machine definitely needs a BIOS update in order to avoid the "CPU power state stuck" bug.

 

The same happened with Thinkpad Helix and you solved it with a new BIOS.

Please release a BIOS for Z510 too!

 

I really appreciate any help you can provide.

Reply
Options

52 Posts

12-26-2013

Austria

111 Signins

1183 Page Views

  • Posts: 52
  • Registered: ‎12-26-2013
  • Location: Austria
  • Views: 1183
  • Message 5 of 419

Re: Lenovo Z510 CPU stuck at 0.77GHz

2014-02-15, 13:07 PM

I can confirm this problem. The Z510 is clocking down the CPU when the battery gets under 20%. Sometimes it stays there even when the battery is already charged.

 

Just perform a reboot and it will work fine again. Hope Lenovo is working on that.

Reply
Options

34 Posts

02-19-2014

Nederland

90 Signins

709 Page Views

  • Posts: 34
  • Registered: ‎02-19-2014
  • Location: Nederland
  • Views: 709
  • Message 6 of 419

Re: Lenovo Z510 CPU stuck at 0.77GHz

2014-02-20, 12:46 PM

I noticed the same issue.

Someone found it might be related to the IGP driver: http://forums.lenovo.com/t5/IdeaPad-Y-U-V-Z-and-P-series/Ideapad-Z510-intel-hd-graphic-slows-down-cpu/m-p/1401711

My battery is always full. 

I've seen the issue on Win7 and Win8 so there's definately something wrong with this notebook.

Reply
Options

50 Posts

01-30-2014

Hungary

53 Signins

710 Page Views

  • Posts: 50
  • Registered: ‎01-30-2014
  • Location: Hungary
  • Views: 710
  • Message 7 of 419

Re: Lenovo Z510 CPU stuck at 0.77GHz

2014-02-20, 13:13 PM

Thanks for the link.

 

However I'm pretty sure it has nothing to do with the IGP driver (or any other drivers), since the problem is exists on linux too. Most probably all of the OS's are affected.

I've read in the Helix thread that the CPU sometimes stuck in the new C7 power state. (new in Ivy Bridge architecture)

 

Maybe the CPU itself has a malfunctioning microcode. In this case of course it cannot be repaired unless Lenovo create a new BIOS and disable the C7 powerstate. Or it would be even better to let this function optional (enable/disable) in BIOS.

Reply
Options

34 Posts

02-19-2014

Nederland

90 Signins

709 Page Views

  • Posts: 34
  • Registered: ‎02-19-2014
  • Location: Nederland
  • Views: 709
  • Message 8 of 419

Re: Lenovo Z510 CPU stuck at 0.77GHz

2014-02-20, 13:27 PM

Thanks for the reply.

If the problem exsist in Linux it's probaly not the IGP driver.

I've update the ME firmware (+driver) but that didn't help either so it's not in Intel's part of the bios.

I think Lenovo needs to look into this and probably a bios update is required to fix this.

 

Strange thing is that I cannot reproduce the problem every time.

Mostly it happens when the notebook is on the charger, I unplug it and start Windows. Youtube videos start lagging and when I check the CPU speed it's on 0.77GHz. Then I use Winrar benchmark to see if the multiplier increases.

If it doens't I need to reboot and the problem is gone.

If it's the C7 powerstate something needs to trigger this state, but I'm unsure what.

I have the i5-4200m b.t.w

 

Unfortunately Lenovo uses Phoenix/Insyde bioses. If they'd used AMI I could have had a look with AMIBCP.

 

Reply
Options

50 Posts

01-30-2014

Hungary

53 Signins

710 Page Views

  • Posts: 50
  • Registered: ‎01-30-2014
  • Location: Hungary
  • Views: 710
  • Message 9 of 419

Re: Lenovo Z510 CPU stuck at 0.77GHz

2014-02-20, 13:41 PM

What do you mean about ME? Isn't it the Intel Management Engine Interface (IMEI)? Because it is just a simple driver too.
I think that the fix needs to be added in a very low level of HAL.

Reply
Options

34 Posts

02-19-2014

Nederland

90 Signins

709 Page Views

  • Posts: 34
  • Registered: ‎02-19-2014
  • Location: Nederland
  • Views: 709
  • Message 10 of 419

Re: Lenovo Z510 CPU stuck at 0.77GHz

2014-02-20, 13:54 PM

The Management Engine firmware is Intel's part which manufacturers cannot edit. Not sure what inside exactly, but it does house CPU management. Updating from Sandy bridge (ME7) to Ivy bridge (ME8) required an ME update in order to make them work.

http://forums.tweaktown.com/gigabyte/54860-about-intel-management-engine-firmware.html

ME firmware contains different modules : AMT (Active Management Technology), ASF (Alert Standard Format), QST (Quiet System Technology) and TPM (Trusted Platform Module) forhardware remotely management… but it also contains chipset’s settings (clocks, frequencies,...) which affect important parameters as BCLK, RAM, Turbo Boost, fans speeds…

 

 

I used 9.0.31.1487 (Haswell) for HM86 but it didn't help:

http://www.win-raid.com/t171f39-Intel-Management-Engine-Drivers-Firmware-and-Tools.html

So I'd advice not to bother. Lenovo needs to fix this.

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete

X

No, I don’t want to share ideas Yes, I agree to these terms