Welcome to our peer-to-peer forums, where owners help owners. Need help now? Visit eSupport here.

English Community

Lenovo NotebooksLenovo P, Y and Z series Notebooks
All Forum Topics
Options

34 Posts

02-19-2014

Nederland

90 Signins

709 Page Views

  • Posts: 34
  • Registered: ‎02-19-2014
  • Location: Nederland
  • Views: 709
  • Message 21 of 419

Re: Lenovo Z510 CPU stuck at 0.77GHz

2014-03-07, 23:23 PM

Thanks for the help.

 

Can this be fixed via a bios update?

 

Reply
Options

50 Posts

01-30-2014

Hungary

53 Signins

710 Page Views

  • Posts: 50
  • Registered: ‎01-30-2014
  • Location: Hungary
  • Views: 710
  • Message 22 of 419

Re: Lenovo Z510 CPU stuck at 0.77GHz

2014-03-08, 16:21 PM

Thank you for noticing this problem. I've sent you a PM.

Reply
Options

2651 Posts

03-21-2012

Malaysia

2405 Signins

55976 Page Views

  • Posts: 2651
  • Registered: ‎03-21-2012
  • Location: Malaysia
  • Views: 55976
  • Message 23 of 419

Re: Lenovo Z510 CPU stuck at 0.77GHz

2014-03-10, 1:45 AM

Hi all,

 

thanks you posting and send me your PM's. I've since escalated this issue to our teams for further investigation. At the moment I'm awaiting further feed back on the case. I'll post more as soon as i can get an update.

 

Regards

Reply
Options

2651 Posts

03-21-2012

Malaysia

2405 Signins

55976 Page Views

  • Posts: 2651
  • Registered: ‎03-21-2012
  • Location: Malaysia
  • Views: 55976
  • Message 24 of 419

Re: Lenovo Z510 CPU stuck at 0.77GHz

2014-03-12, 3:06 AM
hi all

thanks for posting. Just to give you an update our teams are stll investigating this further and I'm currently awaiting there feedback and results.

During this time I'd like to ask if anyone has updated the Lenovo energy management software? If you have not could you try updating Lenovo Energy management software from the below link.

Win7 :
http://support.lenovo.com/en_US/downloads/detail.page?DocID=DS036175

Win 8 :
http://support.lenovo.com/en_US/downloads/detail.page?DocID=DS036850

Win8.1 :
http://support.lenovo.com/en_US/downloads/detail.page?DocID=DS040484
Reply
Options

50 Posts

01-30-2014

Hungary

53 Signins

710 Page Views

  • Posts: 50
  • Registered: ‎01-30-2014
  • Location: Hungary
  • Views: 710
  • Message 25 of 419

Re: Lenovo Z510 CPU stuck at 0.77GHz

2014-03-12, 16:02 PM

Hi NINE,

 

I've updated the package however it is strange that the "Lenovo Energy Management Driver version 1.0.0.28" contains the Energy Management software itself but the new package (8.0.2.43) doesn't.

 

Anyway the problem occured again right after i've installed the new driver so unfortunately this is not solution.

Reply
Options

8 Posts

03-06-2014

26 Signins

130 Page Views

  • Posts: 8
  • Registered: ‎03-06-2014
  • Location:
  • Views: 130
  • Message 26 of 419

Re: Lenovo Z510 CPU stuck at 0.77GHz

2014-03-12, 18:39 PM

@NINE thanks for your work man, i'll update my pc and send you the feedback as soon as posible.

Reply
Options

34 Posts

02-19-2014

Nederland

90 Signins

709 Page Views

  • Posts: 34
  • Registered: ‎02-19-2014
  • Location: Nederland
  • Views: 709
  • Message 27 of 419

Re: Lenovo Z510 CPU stuck at 0.77GHz

2014-03-12, 19:07 PM

Same here.

 

I actually had these driver installed, but was missing the Engery Manager itself.

Installing version 1.0.0.28 solved that but still the CPU is stuck @ 800 MHz.

 

Just discovered something strange. Cold boot to Windows on battery and the CPU is stuck. Plug and unplug the power supply and the CPU throttles up again.

Reply
Options

8 Posts

03-06-2014

26 Signins

130 Page Views

  • Posts: 8
  • Registered: ‎03-06-2014
  • Location:
  • Views: 130
  • Message 28 of 419

Re: Lenovo Z510 CPU stuck at 0.77GHz

2014-03-12, 20:01 PM

@lejohn, exactly same here. cold boot on battery stuck , plug in and plug out, everythings fine. here also after cold boot on batery, reboot on batery and everythings fine again.  

Reply
Options

4 Posts

01-18-2014

Austria

12 Signins

68 Page Views

  • Posts: 4
  • Registered: ‎01-18-2014
  • Location: Austria
  • Views: 68
  • Message 29 of 419

Re: Lenovo Z510 CPU stuck at 0.77GHz

2014-03-12, 22:06 PM

I have the same problem here, the cpu is stuck after a cold boot and as soon as the power supply is plugged the cpu is working again, even when it is unplugged afterwards.

 

I've also sent my laptop to lenovo to get this fixed, but there was nothing done about it. The answer was that everything was working fine already and they did not find any problems.

 

But obviously this is not the case, I really hope this problem can be solved soon..

Reply
Options

2651 Posts

03-21-2012

Malaysia

2405 Signins

55976 Page Views

  • Posts: 2651
  • Registered: ‎03-21-2012
  • Location: Malaysia
  • Views: 55976
  • Message 30 of 419

Re: Lenovo Z510 CPU stuck at 0.77GHz

2014-03-13, 3:06 AM

Hi all,

 

Aprrreciate you sharing your feed back. thanks for that. It is strang to as when the machine is now acting differently now after EM update. Quick check though, You mentioned that from Cold boot the CPU gets stuck. Now plugging and unplugging the the machine got it back to normal again? Just wanted to be sure i understood the scenario correctly here.

 

Another question though, what happens when the when you power the machine over night and start it up again in the morning? do you still have to go through the plugging and unplugging again?

 

 

Hope ot hear back.

 

Regards.

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete

X

No, I don’t want to share ideas Yes, I agree to these terms

Most Liked Authors

(Last 7 days)

View All