Welcome to our peer-to-peer forums, where owners help owners. Need help now? Visit eSupport here.

English Community

Lenovo NotebooksLenovo P, Y and Z series Notebooks
All Forum Topics
Options

5 Posts

04-16-2014

malaysia

19 Signins

187 Page Views

  • Posts: 5
  • Registered: ‎04-16-2014
  • Location: malaysia
  • Views: 187
  • Message 321 of 419

Re: Lenovo Z510 CPU stuck at 0.77GHz

2014-09-18, 10:02 AM

the cpu and gpu in my z510 perform very bad without power supply... is it normal if the lappy uses hd4600 insted of gt740  when im not connected to the power supply?

sorry about the post in the wrong forum. since all of us are  using the same device, i just wanted to know if this is a problem which happens to me alone so  i could do something about it...

Reply
Options

1609 Posts

09-16-2014

United States of America

3048 Signins

61403 Page Views

  • Posts: 1609
  • Registered: ‎09-16-2014
  • Location: United States of America
  • Views: 61403
  • Message 322 of 419

Re: Lenovo Z510 CPU stuck at 0.77GHz

2014-09-25, 17:50 PM

An update: Lenovo continues to investigate forum reports regarding the Z510 CPU.

 

I am in the process of getting clarification on whether the "new" BIOS posted on 8/28 is in fact V40, or if V39 was posted both in May and August.

 

http://support.lenovo.com/us/en/products/laptops-and-netbooks/ideapad-z-series-laptops/ideapad-z510-notebook/downloads/DS100474

 

Thanks,

Reply
Options

3 Posts

09-18-2014

United States

11 Signins

47 Page Views

  • Posts: 3
  • Registered: ‎09-18-2014
  • Location: United States
  • Views: 47
  • Message 323 of 419

Re: Lenovo Z510 CPU stuck at 0.77GHz

2014-09-25, 18:07 PM
Thanks for your time Amy, hopefully we can get this resolved.
Reply
Options

8 Posts

10-07-2014

philippines

14 Signins

112 Page Views

  • Posts: 8
  • Registered: ‎10-07-2014
  • Location: philippines
  • Views: 112
  • Message 324 of 419

Re: Lenovo Z510 CPU stuck at 0.77GHz

2014-10-07, 6:06 AM

hello...i too have problems with my Z510. I found it sluggish and veeeery slow considering it was a quad core i-7. it too was stuck at .77ghz and upon searching the net found this fix:
right click on windows icon (lower left of screen) on desktop. choose RUN. then type msconfig. goto the BOOT TAB and look for ADVANCED OPTIONS. by default the check box of number of processors is clear. CHECK IT and choose the highest number it can reach...mine is on 8. click OK and restart your z510. i noticed after restart that my laptop was snappier, FASTER and overall performed better after doing this....
and on task manager my performance as far as speed is concerned changes from XXX to 2.8ghz unlike the static .77ghz before. hope this helps

Reply
Options

1 Posts

10-10-2014

Turkey

4 Signins

15 Page Views

  • Posts: 1
  • Registered: ‎10-10-2014
  • Location: Turkey
  • Views: 15
  • Message 325 of 419

Re: Lenovo Z510 CPU stuck at 0.77GHz

2014-10-10, 6:41 AM

Hi,

 

I don't really understand why we can't return this laptop. This is the first time I ever purchased a Lenovo product and it's been a really frustrating experience. Looking at all these threads about Z510, this is a model to avoid for anyone else. I have never had so many issues with a laptop in the first year. 6 months and I have already got a dead battery, broken touchpad and this 0.77 problem which Lenovo says it's fixed with the latest BIOS version, which doesn't really fix anything.   /rant

 

Anyways, the only solution I have found was to download ThrottleStop 6.0 which allows you to modify CPU multiplier along with a lot of other stuff. You can easily set 4 different profiles and set the multiplier as you wish (you can go Turbo as well, as you can see in the image). This is a permanent solution unless you want to wait months for a new BIOS update. You just need to watch the CPU temperature and not go too high when you don't need it.

 

(you may see it in the screenshot attached)

 

good luck

 

throttlestop.png

Reply
Options

236 Posts

05-09-2010

Cochrane

1681 Signins

10422 Page Views

  • Posts: 236
  • Registered: ‎05-09-2010
  • Location: Cochrane
  • Views: 10422
  • Message 326 of 419

Re: Lenovo Z510 CPU stuck at 0.77GHz

2014-10-11, 3:38 AM

ThrottleStop 7.00 beta 3

https://www.sendspace.com/file/oquhg3

 

The latest version is a work in progress but it has a few more features so you can take control of your 4th Gen CPU and fix the stuck at 798 MHz problem.

Reply
Options

1609 Posts

09-16-2014

United States of America

3048 Signins

61403 Page Views

  • Posts: 1609
  • Registered: ‎09-16-2014
  • Location: United States of America
  • Views: 61403
  • Message 327 of 419

Re: Lenovo Z510 CPU stuck at 0.77GHz

2014-10-19, 19:59 PM

Update: I escalated this issue internally today.

 

My thanks to benzema79 and BumbuliIII for the additional info and screenshots, as I was able to reference the information you provided in the new case.

 

Thanks for your continued patience,

Reply
Options

50 Posts

01-30-2014

Hungary

53 Signins

710 Page Views

  • Posts: 50
  • Registered: ‎01-30-2014
  • Location: Hungary
  • Views: 710
  • Message 328 of 419

Re: Lenovo Z510 CPU stuck at 0.77GHz

2014-10-19, 20:08 PM

Thanks Amy!

 

All our hope is in you. :)

Reply
Options

3 Posts

10-21-2014

Serbia

19 Signins

56 Page Views

  • Posts: 3
  • Registered: ‎10-21-2014
  • Location: Serbia
  • Views: 56
  • Message 329 of 419

Re: Lenovo Z510 CPU stuck at 0.77GHz

2014-10-21, 9:13 AM

So, i have a Lenovo IdeaPad z510 i5-4200m 8GB ram 1TB HDD gt740m. Bought it last week,and from day one,the same issue persist. Did the BIOS update to V39,but nothing. Btw i'm satisfied with the the laptop,except this thing,and i hope,there will be a BIOS update soon :) At least the temps are low,while gaming :D

CPU.jpg

Reply
Options

10 Posts

10-15-2014

Singapore

38 Signins

252 Page Views

  • Posts: 10
  • Registered: ‎10-15-2014
  • Location: Singapore
  • Views: 252
  • Message 330 of 419

Re: Lenovo Z510 CPU stuck at 0.77GHz

2014-10-21, 11:59 AM

I Dont understand Why lenovo engineers cant understand how to fix this issue, With V39 Bios also,the turbo boost functionality doesnt work always,sometimes it gets stuck at 2.45 ghz ,tht happen on direct power,on battery it drags,with arnd 1.15 ghz and arnd...hope lenovo fix this issue soon,and come with a perfect version of bios soon.

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete

X

No, I don’t want to share ideas Yes, I agree to these terms