Welcome to our peer-to-peer forums, where owners help owners. Need help now? Visit eSupport here.

English Community

Lenovo NotebooksLenovo P, Y and Z series Notebooks
All Forum Topics
Options

10 Posts

09-20-2014

Oklahoma, America

8 Signins

41 Page Views

  • Posts: 10
  • Registered: ‎09-20-2014
  • Location: Oklahoma, America
  • Views: 41
  • Message 1 of 1

So very lost: Ethernet not registered. Z40-70

2014-09-20, 18:08 PM

I apologize because I'm pretty sure this is in the wrong area, but I couldn't find specifically for the Z series that wasn't for the IdeaPad.
...unless it is...I really don't know...but I don't think it is...
Anyway. I have Crohn's disease and any measure of stress at all, even trying to read through trouble shooting, sends my guts into a knotting mess. What I'm needing is help with my ethernet connection. Wireless works fine, but I'm trying to use a LAN line for better stability. I have the sucker in there as best as I can and there isn't a light on the side, like everything claims (though my laptop really is pretty slim on how many lights it even has). I just got my laptop hardly a month ago, so this isn't anything from overuse. I've updated the driver and it still doesn't work. I've tried different ethernet cords, that didn't work. Had it directly plugged into the modem, that didn't work. I'm terrified it's the port itself that's faulty somehow. Which would be preposterous considering that I haven't had it very long. 
...........help.

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete

X

No, I don’t want to share ideas Yes, I agree to these terms