English Community

Lenovo NotebooksLenovo P, Y and Z series Notebooks
All Forum Topics
Options

6 Posts

04-24-2017

PK

6 Signins

71 Page Views

  • Posts: 6
  • Registered: ‎04-24-2017
  • Location: PK
  • Views: 71
  • Message 1 of 6

Y510P Not Shifting to AC Adapter After a Disconnection

2017-04-24, 14:45 PM

I am using this laptop from last three years. It was working fine till yesterday before I performed Battery Guage Reset. Now I am facing issue.

 

When I disconnect AC Adapter and Reconnect it to Laptop. Laptop doesn't shift to AC supply and keep draining battery continuously without shifting to AC Power.

 

It Only Shift to AC Power by Following Steps.

 

- Remove Battery from Laptop

- Remove AC Adapter from Socket

- Press Power Button for 30 seconds

- Put AC Adapter in Socket and Laptop and Release Power Button

- Then Computer Will Turn On using AC Adapter

- Insert Battery After that Laptop Charges Battery as Normal Laptop however After disconnection I have to do all this again. 

 

Above way is very incontinent. Every time when I have to remove AC Adapter or there is a power cutoff.

 

Note:

- I am using windows 10 from many months it was okay on windows 10 before.

- My Settings and version of power management has no issues.

- My AC Adapter is fine. It has no issues.

- I am using Latest BIOS available on Lenovo Site

- I tried to update battery firmware however couldn’t find it.

 

Please suggest me some solution ASAP. 

Solved! See the solution
Reply
Options

2953 Posts

02-22-2017

GB

1083 Signins

26243 Page Views

  • Posts: 2953
  • Registered: ‎02-22-2017
  • Location: GB
  • Views: 26243
  • Message 2 of 6

Re: Y510P Not Shifting to AC Adapter After a Disconnection

2017-04-25, 8:25 AM

Hello AbuHuzaifah

Thanks for using the Lenovo forums.


Try to see if you are able to use an alternate charger for the unit, and see if the issue will persist.

 

Hope this helps, let us know how you get on.


==================================================================================
Did someone help you today? Thank them with a Kudo!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"!

 

This will help the rest of the Community with similar issues identify the verified solution and benefit from it.



Pesszimistának lenni a legjobb, vagy igazad van, vagy kellemesen meglepődsz...
Reply
Options

6 Posts

04-24-2017

PK

6 Signins

71 Page Views

  • Posts: 6
  • Registered: ‎04-24-2017
  • Location: PK
  • Views: 71
  • Message 3 of 6

Re: Y510P Not Shifting to AC Adapter After a Disconnection

2017-04-25, 14:53 PM
No. Still same problem.
Reply
Options

6 Posts

04-24-2017

PK

6 Signins

71 Page Views

  • Posts: 6
  • Registered: ‎04-24-2017
  • Location: PK
  • Views: 71
  • Message 4 of 6

Re: Y510P Not Shifting to AC Adapter After a Disconnection

2017-04-25, 16:13 PM
After Reading this https://forums.lenovo.com/t5/Lenovo-P-Y-and-Z-series/Solution-for-laptop-cannot-detect-AC-adapter-after-performing/m-p/1641892


I think my MOSFET is dead and this is a great shame for Lenovo not fixing issue in 3 years. At-least you should remove that bloody **bleep** button from Energy Management utility. I was great fan of Lenovo till today.

0 person found this solution to be helpful.

This helped me too

Reply
Options

3 Posts

10-22-2018

PH

12 Signins

392 Page Views

  • Posts: 3
  • Registered: ‎10-22-2018
  • Location: PH
  • Views: 392
  • Message 5 of 6

Re: Y510P Not Shifting to AC Adapter After a Disconnection

2018-11-08, 6:32 AM

Hello AbuHuzaifah

Did you resolve the issue?

I am following the suggestions in the forum - specifically the posting by Jansilp and Tesafly.

We'll see.

 

 

Reply
Options

3 Posts

10-22-2018

PH

12 Signins

392 Page Views

  • Posts: 3
  • Registered: ‎10-22-2018
  • Location: PH
  • Views: 392
  • Message 6 of 6

Re: Y510P Not Shifting to AC Adapter After a Disconnection

2019-04-26, 3:04 AM

Hello:

 

I followed suggestions from Jansilp, Teslafly, Dave1996 and a few others.  Identified the burnt Mosfet, got a new one soldered and now the laptop is functional again.  Thanks to you all.

 

now I am trying to locate where the culprit - 'energy management firmware' is to disable it so the problem will not happen again (or where the battery gauge reset function is).

 

Thank you to the forum.

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete