Welcome to our peer-to-peer forums, where owners help owners. Need help now? Visit eSupport here.

English Community

Lenovo NotebooksLenovo P, Y and Z series Notebooks
All Forum Topics
Options

2 Posts

03-09-2015

Hungary

7 Signins

49 Page Views

  • Posts: 2
  • Registered: ‎03-09-2015
  • Location: Hungary
  • Views: 49
  • Message 1 of 3

Z50-75 screen error issue...

2015-03-09, 19:39 PM

Dear Lenovo Community!

 

I am so disappointed, because I've bought a Lenovo Z50-75 (configuration: AMD FX 7500, 4gb RAM, Radeon R7  M260DX, 1TB hdd) and it has got some trouble...

 

The main problem is about the screen...  When screen resolution is 1600 X 900, a lot of grey, light squares appear on it, and it starts vibrating (barely). If I set the resolution to fullHD, it slightly changes, but the vibration still appears (the squars will be minor) . BUT it appears only when it works from the battery! If I plug in the AC adapter, it disappears.

 

I've been to the official hungarian Lenovo service, they gave me a NEW laptop, the same type, but the trouble is still stands. That's why I would ask for your help.

 

I've tried many things (for example:  update the drivers, change the OS, etc..) Now I'm using Windows 7 64 bit, but it is the same with Win 8.1 64 bit.

 

Anyone has similar problem? I am so dissatisfied and disappointed.

Waiting for your opinion.

 

And sorry for my English. :)

 

Thanks for your reply in advance!

 

Richard

Reply
Options

6 Posts

03-12-2015

Bulgaria

56 Signins

292 Page Views

  • Posts: 6
  • Registered: ‎03-12-2015
  • Location: Bulgaria
  • Views: 292
  • Message 2 of 3

Re: Z50-75 screen error issue...

2015-03-12, 13:45 PM

Hi, there! I noticed a similar problem right now - I had to unplug the adapter and something went wrong - on some pages of this forum the screen "vibrates" and the image gets bugged - the white areas become noisy. What is interesting that it happens nowhere rather than here so far.

Reply
Options

6 Posts

03-12-2015

Bulgaria

56 Signins

292 Page Views

  • Posts: 6
  • Registered: ‎03-12-2015
  • Location: Bulgaria
  • Views: 292
  • Message 3 of 3

Re: Z50-75 screen error issue...

2015-03-13, 21:58 PM

Hey, I found the solution. :cattongue: Check it here.

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete

X

No, I don’t want to share ideas Yes, I agree to these terms