English Community

Lenovo NotebooksLenovo P, Y and Z series Notebooks
All Forum Topics
Options

10 Posts

06-08-2014

South Carolina

19 Signins

153 Page Views

  • Posts: 10
  • Registered: ‎06-08-2014
  • Location: South Carolina
  • Views: 153
  • Message 11 of 56

Re: Z510 random shut downs (hard) when plugged in

2014-08-27, 15:57 PM

Got my laptop back yesterday and it's running fine now. I tossed the work order slip but the items that failed under testing (and I'm assuming replaced?) were the motherboard and battery. It was just a list of boxes of what was tested and passed/failed.

 

The process for me was:

1. Was sent a new adapter

2. Phone/web support for installing 8.0 drivers

3. Sending back laptop

 

It ran last night without issues, I was editing a large batch of photos from vacation and needed to stay plugged in. No random shutdowns!

Reply
Options

4 Posts

09-05-2014

Quezon City Philippines

4 Signins

33 Page Views

  • Posts: 4
  • Registered: ‎09-05-2014
  • Location: Quezon City Philippines
  • Views: 33
  • Message 12 of 56

Re: Z510 random shut downs (hard) when plugged in

2014-09-05, 8:47 AM

so it is the motherboard and battery that were replaced?  i think I will also send my laptop to lenovo service center.

Reply
Options

17 Posts

10-06-2014

Philippines

38 Signins

114 Page Views

  • Posts: 17
  • Registered: ‎10-06-2014
  • Location: Philippines
  • Views: 114
  • Message 13 of 56

Re: Z510 random shut downs (hard) when plugged in

2014-11-07, 14:55 PM

What was replaced my model is Z410 its very similar

Reply
Options

1 Posts

11-12-2014

India

2 Signins

41 Page Views

  • Posts: 1
  • Registered: ‎11-12-2014
  • Location: India
  • Views: 41
  • Message 14 of 56

Re: Z510 random shut downs (hard) when plugged in

2014-11-12, 13:59 PM

really this is one of the worst laptop, even the engineer cant solve the problem. lenovo please come up with a proper power supply adapter. stop creating laptop that the company cannot provide its proper functions.

Reply
Options

7 Posts

01-11-2015

8 Signins

64 Page Views

  • Posts: 7
  • Registered: ‎01-11-2015
  • Location:
  • Views: 64
  • Message 15 of 56

Re: Z510 random shut downs (hard) when plugged in

2015-01-11, 20:31 PM

I have exactly the same issue...

Reply
Options

7 Posts

01-11-2015

8 Signins

64 Page Views

  • Posts: 7
  • Registered: ‎01-11-2015
  • Location:
  • Views: 64
  • Message 16 of 56

Re: Z510 random shut downs (hard) when plugged in

2015-02-01, 2:19 AM

how about it right now? 

I have mine repaired, and they replaced the motherboard,

but now, the issue still keep happening...

Reply
Options

7 Posts

01-11-2015

8 Signins

64 Page Views

  • Posts: 7
  • Registered: ‎01-11-2015
  • Location:
  • Views: 64
  • Message 17 of 56

Re: Z510 random shut downs (hard) when plugged in

2015-02-02, 6:25 AM

how about it right now? 

Reply
Options

10 Posts

06-08-2014

South Carolina

19 Signins

153 Page Views

  • Posts: 10
  • Registered: ‎06-08-2014
  • Location: South Carolina
  • Views: 153
  • Message 18 of 56

Re: Z510 random shut downs (hard) when plugged in

2015-02-03, 22:29 PM

wrote:

Got my laptop back yesterday and it's running fine now. I tossed the work order slip but the items that failed under testing (and I'm assuming replaced?) were the motherboard and battery. It was just a list of boxes of what was tested and passed/failed.

 

The process for me was:

1. Was sent a new adapter

2. Phone/web support for installing 8.0 drivers

3. Sending back laptop

 

It ran last night without issues, I was editing a large batch of photos from vacation and needed to stay plugged in. No random shutdowns!


For those asking, I have had no issues in the past 6 months since receiving back my laptop. Motherboard and battery were replaced (no cost to me, all under the 1 year warranty).

 

Honestly feel this laptop holds the best options at the best price compared to other manufacturers. And once I did make my case with customer service they were quick to correct the hardware issue.

 

Now if someone can figure out why my Lenovo N700 mouse keeps disconnecting via bluetooth that'd be great.

http://forums.lenovo.com/t5/Options-Accessories/N700-Mouse-scrolling-amp-8-1-gesturing-erratically/m-p/1809119

Reply
Options

4 Posts

09-05-2014

Quezon City Philippines

4 Signins

33 Page Views

  • Posts: 4
  • Registered: ‎09-05-2014
  • Location: Quezon City Philippines
  • Views: 33
  • Message 19 of 56

Re: Z510 random shut downs (hard) when plugged in

2015-02-04, 0:23 AM
hi.. so far so good.. problem was fixed by replacing the charging port
where we plug in the power adaptor..

Reply
Options

7 Posts

11-07-2015

Egypt

9 Signins

91 Page Views

  • Posts: 7
  • Registered: ‎11-07-2015
  • Location: Egypt
  • Views: 91
  • Message 20 of 56

Re: Z510 random shut downs (hard) when plugged in

2015-11-07, 0:51 AM

i have the same problen , and iam very disppointed ; i want to complain ; this is  a very bad laptob

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete