English Community

Lenovo NotebooksLenovo P, Y and Z series Notebooks
All Forum Topics
Options

3 Posts

01-06-2020

GB

8 Signins

96 Page Views

  • Posts: 3
  • Registered: ‎01-06-2020
  • Location: GB
  • Views: 96
  • Message 1 of 3

Z70-80 Num Lock turning off and on randomly and not responding

2020-01-07, 0:12 AM

The num lock on my Z70-80 randomly turns itself off and on (sometimes very quickly causing the toggle key pop up), and doesn't respond to me pressing the key. The trackpad also becomes very slow or stops working and the pointer disappears when this happens.

So far I have tried re-installing the drivers for the keyboard and mouse, ran a full system antivirus and windows defender scan, removing the battery for a static discharge, and using safe mode. 

I've also ran the Lenovo diagnostic and it passed with no issues.

I'm running Windows 10, and have checked that there are no outstanding updates.

The keyboard is clean and hasn't been damaged in any way.

Does anybody have any ideas how to solve this?

 

Thanks :)

Reply
Options

445 Posts

11-04-2019

US

169 Signins

12767 Page Views

  • Posts: 445
  • Registered: ‎11-04-2019
  • Location: US
  • Views: 12767
  • Message 2 of 3

Re: Z70-80 Num Lock turning off and on randomly and not responding

2020-01-07, 11:31 AM

 

Welcome to the Community Forums Confused5!

 

Nice to have you here!

 

Would just like to get additional details from you for this to be sorted out:

 

  • Does this also happens when you're on the sign in page?
  • Can you also provide us your device's machine type-model/MTM number?
  • Does this also happens when using an external keyboard?

Please use this linkto update your device's BIOS and Power Manager driver.

 

Also, try to turn off the mouse key on your device, here's how:

 

  • Go to the Control Panel from the Start Menu
  • Navigate to the Ease of Access Center
  • Go to Make the keyboard easier to use
  • Navigate to Control the mouse with the keyboard and uncheck the “Turn On Mouse Keys” option
  • Click on Apply and then on OK

You may also launch/open Registry Editor to configure the keyboard manually should the above steps didn't worked, here's the steps:

 

  • Press Windows key and R button on the keyboard and type in regedit
  • Look for Keyboard under Control Panel tab on the left side of the page
  • Look for InitialKeyboardIndicators, double click it and set its value to 2 (two) then click OK
  • Once done, search for HKEY_USERS on the left side of the page and set a registry string in the name InitialKeybaordIndicators and set the value to 2147483648
  • Click OK, close Registry Editor and restart the laptop

Update us how it goes, we'll be waiting for your response.

 

Thanks!

 



Did someone help you today? Press the star on the left to thank them with a Kudo!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"! This will help the rest of the Community with similar issues identify the verified solution and benefit from it.

Follow us @LenovoSupport on Facebook and Twitter!

Reply
Options

3 Posts

01-06-2020

GB

8 Signins

96 Page Views

  • Posts: 3
  • Registered: ‎01-06-2020
  • Location: GB
  • Views: 96
  • Message 3 of 3

Re: Z70-80 Num Lock turning off and on randomly and not responding

2020-01-17, 16:52 PM

Hi Adriel_lenovo,

 

Thanks for the suggestions. I did try them, but nothing seemed to work. I had to admit defeat and take it to a repair shop, and they confirmed that unfortunately, after 4 and a half years, the motherboard had died :(

 

Thank you for your help though,

 

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save