cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Arctos_
Fanfold Paper
Posts: 20
Registered: ‎03-25-2014
Location: CA
Views: 519
Message 1 of 3

170w Charger is clicking/making noise.

I just plugged in my charger and sat it close to me for the first time since buying it. It is making some sort of clicking noise as it charges.

 

At first I thought it was my hard drive, but I've definitely isolated it in the charger. 

 

Is this okay? I don't think electronics should click, though I am no expert.

 

EDIT: Oh, and the clicking is completely random, there is no pattern to the clicks.

Highlighted
Social Support Agent
Social Support Agent
Posts: 5,822
Registered: ‎02-11-2012
Location: PH
Views: 489
Message 2 of 3

Re: 170w Charger is clicking/making noise.

hi Arctos,

 

Did you notice if the clicking occurs when just browsing the web or playing a graphically extensive game? Also, does the AC adapter heat up that it's too hot to touch when it clicks?

 

If the clicking noise on the AC adapter happens when playing a game and/or when the AC adapter heats up then I don't think that this is okay as this may indicate a problem with the cord or on how the AC adapter converts the current (could be a malfunctioning component inside). I recomend you contact Lenovo and report the issue

 

Telephone number: 1-877-453-6686

Hours of operation: 24 hours a day / 7 days a week

 

You may also wanna check this thread for more info (although it's quite old).

 

 

Regards



Did someone help you today? Press the star on the left to thank them with a Kudo!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"! This will help the rest of the Community with similar issues identify the verified solution and benefit from it.

Follow us @LenovoSupport on Facebook and Twitter!

Arctos_
Fanfold Paper
Posts: 20
Registered: ‎03-25-2014
Location: CA
Views: 483
Message 3 of 3

Re: 170w Charger is clicking/making noise.

Hi neokenchi, 

 

Thanks for the reply! When I noticed it I was browsing the web while doing downloads (About 8mbit/sec), but then I went to school. I'll plug it in later today and see if the problem persists. Then I'll comtact Lenovo. I doubt that this is normal and theres probably a loose connection somewhere in the brick, or even a short. 

 

Probably not a short though, as it doesn't get abnorally hot, or that hot at all.

Check out current deals!


Shop current deals

Top Kudoed Authors