cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
rambomhtri
SCSI Port
Posts: 89
Registered: ‎12-14-2013
Location: Germany
Views: 817
Message 1 of 7

American Y510p writting spanish

Hi, I have an american Lenovo Ideapad Y510p, with an american keyboard. Well, when I'm writing in spanish, I press "Windows key + space bar" to change the language of the keyboard. Everything is just fine, except one:

I can NOT type these 2 symbols "<" and ">". I've used every combination I know, and those will never appear when I have change the koyboard to spanish. I've tried a mapkeyboard software, but most of them don't work in windows 8.1 and if so, they can't change my key's by a combination I choose. I'd like to type those 2 symbols pressing "alt + ," and "alt + .", that right now don't do anything.

Thanks!

My laptop:
Lenovo Y510p, Intel Quad-Core i7-4700MQ up to 3.4GHz, Intel HD Graphics 4600, nVIDIA GeForce GT 755M 2GB GDDR5, 8GB RAM, 15.6" Full HD, 1TB 5400rpm HDD + 24GB SSD M.2 (cache), Intel Wireless-N 7260, 72Wh
Social Support Agent
Social Support Agent
Posts: 5,824
Registered: ‎02-11-2012
Location: PH
Views: 795
Message 2 of 7

Re: American Y510p writting spanish

hi rambomhtri,

 

Try using AutoHotKey and edit the AutoHotkey.ahk script in the Documents folder to show the following:

 

!,::
Send <
return

!.::
Send >
return

When done,  reload AutoHotKey (click File > Reload Script) and observe.

 

 

Regards



Did someone help you today? Press the star on the left to thank them with a Kudo!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"! This will help the rest of the Community with similar issues identify the verified solution and benefit from it.

Follow us @LenovoSupport on Facebook and Twitter!

rambomhtri
SCSI Port
Posts: 89
Registered: ‎12-14-2013
Location: Germany
Views: 776
Message 3 of 7

Re: American Y510p writting spanish

**bleep** right, dude!

Now if I press the "Alt" (left) and the key "</,", it shows "<", as I wanted. Now what I have to do? Is it permanently? Do I need to install anything? If I delete the new file that has appeared in My Documents, this stop works, right?
My laptop:
Lenovo Y510p, Intel Quad-Core i7-4700MQ up to 3.4GHz, Intel HD Graphics 4600, nVIDIA GeForce GT 755M 2GB GDDR5, 8GB RAM, 15.6" Full HD, 1TB 5400rpm HDD + 24GB SSD M.2 (cache), Intel Wireless-N 7260, 72Wh
Social Support Agent
Social Support Agent
Posts: 5,824
Registered: ‎02-11-2012
Location: PH
Views: 710
Message 4 of 7

Re: American Y510p writting spanish

hi rambomhtri,

 

Good to know it's working. Yes, if you delete the AutoHotKey.ahk file under Documents or if the AutoHotKey app is not running, the keyboard will be back to normal, otherwise, it will always remap the keys.

 

 

Regards



Did someone help you today? Press the star on the left to thank them with a Kudo!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"! This will help the rest of the Community with similar issues identify the verified solution and benefit from it.

Follow us @LenovoSupport on Facebook and Twitter!

rambomhtri
SCSI Port
Posts: 89
Registered: ‎12-14-2013
Location: Germany
Views: 680
Message 5 of 7

Re: American Y510p writting spanish

Yeah, I have to keep that file and run the application in order to remap it.

Thank you a lot.

Now, my question is: is there a way I can keep that remap configuration always? Registry or something like that, so I don't have to install 3rd parties software to write correctly?

It's not too nice having to start a program everytime I turn on the computer to write some symbols, I know it can autostart, but you know....

My laptop:
Lenovo Y510p, Intel Quad-Core i7-4700MQ up to 3.4GHz, Intel HD Graphics 4600, nVIDIA GeForce GT 755M 2GB GDDR5, 8GB RAM, 15.6" Full HD, 1TB 5400rpm HDD + 24GB SSD M.2 (cache), Intel Wireless-N 7260, 72Wh
Social Support Agent
Social Support Agent
Posts: 5,824
Registered: ‎02-11-2012
Location: PH
Views: 454
Message 6 of 7

Re: American Y510p writting spanish

hi rambomhtri,

 

AFAIK, one way to make this change permanent is to add the AutoHotKey.ahk file into the startup folder so that it will always automatically run when you login to Windows.

 

To add startup items, navigate to this location and paste the file:

C:\Users\<User Profile folder name>\AppData\Roaming\Microsoft\Windows\Start Menu\

 

In addition, you can add these lines into the AutoHotKey.ahk file to pause or exit the autohotkey app.

 

^+s::Pause
^+x::ExitApp

Hotkeys:

Ctrl+Shift+S  - pauses autohotkey

Ctrl+Shift+X  - exits autohotkey

 

Guide:

How To Edit Startup Items In Windows 8

 

 

Regards



Did someone help you today? Press the star on the left to thank them with a Kudo!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"! This will help the rest of the Community with similar issues identify the verified solution and benefit from it.

Follow us @LenovoSupport on Facebook and Twitter!

rambomhtri
SCSI Port
Posts: 89
Registered: ‎12-14-2013
Location: Germany
Views: 314
Message 7 of 7

Re: American Y510p writting spanish

Thanks, but again, I must have this 3rd party software. I'd like to uninstall AutoHotKey, and be able to do this without any software. Something like create this "alt+," feature built-in the keyboard driver. May be some registry changes?

I mean, AutoHotKey is awesome, but I don't like the idea of setting it up in the startup just to write 2 symbols.

Cheers!

My laptop:
Lenovo Y510p, Intel Quad-Core i7-4700MQ up to 3.4GHz, Intel HD Graphics 4600, nVIDIA GeForce GT 755M 2GB GDDR5, 8GB RAM, 15.6" Full HD, 1TB 5400rpm HDD + 24GB SSD M.2 (cache), Intel Wireless-N 7260, 72Wh

Check out current deals!


Shop current deals

Top Kudoed Authors