cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
akampad
Paper Tape
Posts: 1
Registered: ‎10-26-2017
Location: IR
Views: 2,359
Message 1 of 5

BIOS Settings don't Save after Laptop Restart

Hi and sorry about my bad Engish writtig Smiley Happy

 

I have a Ideapad Z50-70 with below configuration:

CPU: i7 4170U

GPU: Nvidia 840M 4G

256GB Samsung Evo 850 SSD

12GB DDR3 RAM

 

I have 3 problems with my laptop:

  1. First: BIOS settings reset to default after restating Smiley Happy I really don't know why but everytime I try to make some changes to my laptop BIOS don't save them. Time and date have no problem and shows current date and time.
  2. Second: Can't boot from USB I have a Ubuntu bootable USB and it work on other laptops but not on my system. My laptop just can boot from DVDs
  3. And third: Ubnutu boot faild Smiley Sad After reinstalling Ubuntu 17.10 .. whenever I turn on my laptop a blue dialog in a blank screen comes up and sys that "ubuntu boot faild"

Now .. Please help me to  fix this problems

I don't want to buy a new laptop because I love akampad (Ideapad Z50-70)

 

And final question:

I tried to reinstall or update my BIOS frimware but there is no newer update and when I download the exist driver and tried to install it, it didn't let to continue the installation and said that driver is in same version of installed BIOS version ..

How can I reinstall my BIOS and reinstallation can fix those problems I just mentioned??!!

frost4
Paper Tape
Posts: 2
Registered: ‎11-30-2017
Location: IN
Views: 2,048
Message 2 of 5

Re: BIOS Settings don't Save after Laptop Restart

on B40-70 with ubuntu 17.10, also facing the same issue
rmshah99
Paper Tape
Posts: 6
Registered: ‎12-03-2017
Location: US
Views: 2,022
Message 3 of 5

Re: BIOS Settings don't Save after Laptop Restart

Same issue for Lenovo Z40

mobile_reign
What's DOS?
Posts: 1
Registered: ‎12-30-2017
Location: GR
Views: 1,841
Message 4 of 5

Re: BIOS Settings don't Save after Laptop Restart

Me too,

 

After installing ubuntu 17.10 and fiddling with secure boot so I could install third-party drivers it turned into a mess.

 

Nothing boots (cd,usb) and i've tried both mbr legacy devices and uefi gpt ones. Nothing.

 

Plus, every time I change anything in the bios, they get reset and the cycle continues, 

 

Secure boot always reverts to disabled and legacy option resets to uefi only

 

Reset to default has no effect whatsoever.

CyberSimian
Bit Torrent
Posts: 790
Registered: ‎07-10-2016
Location: GB
Views: 1,832
Message 5 of 5

Check out current deals!


Shop current deals

Top Kudoed Authors