cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Jasiek612
Blue Screen Again
Posts: 12
Location: Melbourne
Views: 2,249
Message 1 of 3

Bricked y510p BIOS

 I have had a y510p for 3 years now and have had numerous problems with it. Having replaced it I decided to use it as a desktop (Screen broke and I just use it connected to a monitor). I wanted to backflash my bios to an earlier verson (from 3.08 to 2.07) and backed up my bios on a bootable USB. The bios backflash was somewhat successful (could get into BIOS and showed that 2.07 was installed) But the screen kept flashing off and on (black background, no image displayed aside from the lenovo splash screen for about .1 of a second). I then tried re-installing my bios from the USB but the machine turned off soon as it started despite being plugged into the wall with no other outlets used and having full charge on the battery.

After that, the laptop would start but no image would be displayed (keyboard light would remain on). I got desperate and flashed and attempted to flash crisis BIOS per this guide http://blog.jimsjump.com/2016/02/07/lenovo-y510p-v305-b... and after a minutes of constant beeping the laptop turned off.

Now when I try turning it on, it quickly turns off and on about 3 times before starting. The keyboard lights up, the fans spin for up to 30 seconds and then the machine turns off and the cycle repeats indefinitely.

I'm 100% sure It's bricked to death now, I was just wondering if there was anything else I could try? I can't even get into BIOS anymore. I was contemplating purchasing new bios chips and re-soldering them, What are your opinions guys?

KarmaMechanic
Punch Card
Posts: 13
Location: US
Views: 2,120
Message 2 of 3

Re: Bricked y510p BIOS

I have a similar bios issue, recently my original 1TB/SSD combo drive failed and I replaced the HD with another 2.5" I had loaded with a retail Windows 8 system. That worked fine, however I decided to do a full set of updates since I was redoing the whole system anyway, unfortunately upon attempting the BIOS update from the original v1.10 to v3.08 (from the lenovo website) the update failed and locked into an infinite reboot cycle which sounds similar to your issue except I have nothing ever displayed.

Mine comes on for about 3 seconds, the keyboard lights come on, but nothing shows on the display, no backlight either, as if it were off, and after about 3 seconds it turns off, stays off for about 3 or 4 seconds and turns on again, and it simply repeats this endlessly if left on.

I have also tried the proceedure on Jim's Jump(attempting to flash the Yx01.bin crisis bios from a usb flash drive) as yet to no avail, but I still have a few ideas. Something I've yet to try, is removing the HD(perhaps forcing it to look to the USB?) then re-trying the proceedure noted on Jim's Jump. I'll likely be trying this later today so I'll update with results once I've attempted it.

For you specifically, I believe I've read that if the bios is still accessable, but simply not displaying to a screen, that the key sequence needed to reset the bios is: F2, Left, Down, Down, Down, Down, Enter, Enter, Enter, Enter. I can't confirm this of course, but I've seen this noted elsewhere. It hasn't worked for me, but might work if your bios is still somewhat accessable and just not visible.

 

I've also read about soldering a replacement bios, but I'm a bit reluctant to attempt it yet. Additionally it may be the case(not yet confirmed) that there are actually two bios chips on the motherboard(IIRC I read this earlier in the context of someones bios problems with the similar y410p model), this sort of makes sence when I think about it, if the bios itself does have an option to reset to factory, it has to get that data from somewhere, physically swaping the main bios with the backup would make sense and leave it with whatever bios was factory original.(Though I'd assume swaping the main for the backup would also make the reset option in the bios menu non-functional and potentially damaging if ever used afterward). If only the engineer who designed the board had made it jumper selectable.... Smiley Frustrated

Besides all this I've been checking into just buying a replacement motherboard for a swap, which I've learned isn't as straight forward as I'd have hoped; because there seems to be at least 12 variations of the "NM-A032" motherboard, for which I'm still not entirely sure of the cross-compatibility. For instance I'm not sure if the VIQY0 NM-A032 versions of the motherboard have any issues which make them incompatible with a system that originally came with a VIQY1- NM-A032 motherboard. I've started to decipher the differences between the various different models, I might start a thread just to expand on that.

Jasiek612
Blue Screen Again
Posts: 12
Location: Melbourne
Views: 2,113
Message 3 of 3

Re: Bricked y510p BIOS

Hey Karma, I bought replacement bios chips after trying every bios-fixing method i could find and resoldering the chips fixed it for me. I noticed that the bios was repeating the whole "screen-off, screen-on" thing but changing the boot from UEFI to Legacy got me in and now everything is working as it should.
Top Kudoed Authors