English Community

Lenovo NotebooksLenovo P, Y and Z series Notebooks
All Forum Topics
Options

6 Posts

10-02-2012

UK

17 Signins

163 Page Views

  • Posts: 6
  • Registered: ‎10-02-2012
  • Location: UK
  • Views: 163
  • Message 1 of 5

Cannot enable wifi using Fn and F5 keys - Y580

2014-06-08, 11:24 AM

I have a problem, normally I press Fn and F5 to bring up the window to enable/disable Wireless Lan and Bluetooth. But it's suddenly stopped working and I cannot switch on my Wireless Lan.

 

This is on IdeaPad Y580 running Windows 7.

 

1. When I press Fn F5 no window opens.

 

2. When I press Fn F6 my track pad is enabled/disabled as normal, although I do not see the notification on screen.

 

3. When I press the Fn and volume or brightness controls, they work perfectly, but again I do not notification on screen, the bars showing level of volume or brightness.

 

4. Also the One Touch Recovery and One Key Theater buttons are not working. But the audio Mute button is working.

 

5. I have uninstalled the Lenovo Energy Management software and reinstalled it but no difference.

 

6. I have checked the BIOS and Wireless Lan is enabled.

 

7. I also saw that in Task Manager I cannot see utility.exe running.

 

This is really causing me problems, can anyone suggest a fix?

 

Thanks, Dave. 

Solved! See the solution
Reply
Options

6 Posts

10-02-2012

UK

17 Signins

163 Page Views

  • Posts: 6
  • Registered: ‎10-02-2012
  • Location: UK
  • Views: 163
  • Message 2 of 5

FIXED! - Cannot enable wifi using Fn and F5 keys - Y580

2014-06-08, 14:18 PM

Finally fixed it...

 

1. I uninstalled and reinstalled the Lenovo Energy management Software - No difference.

 

2. I uninstalled and reinstalled the drivers for the Wireless LAN - No difference.

 

3. I noticed that the OneKey Recovery button wasn't working, so I decided to uninstall and reinstall the OneKey Recovery software...it worked! :smileyhappy:

 

4. In Task Manager I can now see that utility.exe is running as below:

 

Task Manager - utility.exe

 

Now I have no idea why the OneKey Recovery software would affect the Lenovo Wireless Device Settings? :smileyindifferent:

 

But I hope this might help someone else!

 

All the best, Dave.

0 person found this solution to be helpful.

This helped me too

Reply
Options

1 Posts

02-02-2015

Bulgaria

19 Signins

96 Page Views

  • Posts: 1
  • Registered: ‎02-02-2015
  • Location: Bulgaria
  • Views: 96
  • Message 3 of 5

Re: Cannot enable wifi using Fn and F5 keys - Y580

2015-02-07, 22:14 PM

I did the same thing as u said and the ultility.exe thing is working i have reinstalled the energy management drivers and still not working can u give me a hand?

Reply
Options

10 Posts

07-29-2013

United Kingdom

9 Signins

73 Page Views

  • Posts: 10
  • Registered: ‎07-29-2013
  • Location: United Kingdom
  • Views: 73
  • Message 4 of 5

Re: Cannot enable wifi using Fn and F5 keys - Y580

2016-05-29, 15:47 PM

[Solution to fn+F5 not working]

I faced the issue of WiFi not being enabled in May 2016 (suddenly fn+F5 stopped working and I could not reenable the WiFi on my Lenovo Y580) after many of the forum posts had been written. None of the proposed solutions I came across solved my problem. Now I found a solution and am here to share it: Go to Lenovo support page http://support.lenovo.com/br/en/ and select your laptop (mine was Ideapad Y series (ideapad) Y580 model bought back in 2012, great machine), select your operating system, mine is Windows 7 (64-bit) and download and install the BIOS update. I don't know why, but flashing (updating) the BIOS worked, once computer restarted fn+F5 worked again, as well as the "A" symbol on the screen when Caps Lock was pressed started appearing again as well.

 

Below I will list all the things I tried from forum and Lenovo pages to solve the problem that did not solve it (but may solve your problem in case updating the BIOS won't do):

- Going on Control Panel/Network and Internet/Change adapter Settings and enabling the Intel wireless connection: Windows cannot enable it, it actually recommends you use a physical switch or use function keys when you use the "diagnosys" function.

- Going on Win+R\msconfig\startup and enabling all "Startup Item"s named "Lenovo ...". (Strangely, my "startup" list does not contain "Lenovo Utility" item as I have seen on the internet, not even now when all is working well.)

- Going on BIOS (restarting computer and pressing F2 when Lenovo icon appears) and disabling the Wireless connection, then restarting, going on BIOS again and enabling the Wireless connection.

- Uninstaling and installing again the other software for download at the support page for my laptop model, "Lenovo Onekey Recovery" and "Power Management", or installing the "HotFix" listed there.

- Plugging my computer to a monitor, using "extended option" to extend desktop to both screens (laptop and monitor) and trying fn+F5 (I thought the dialog box was opening on a hidden area of the desktop as I sometimes use a monitor)


Now that was 2 hours finding the fix to this problem that I will never get back. Best of luck!

Reply
Options

2 Posts

08-23-2015

BR

9 Signins

110 Page Views

  • Posts: 2
  • Registered: ‎08-23-2015
  • Location: BR
  • Views: 110
  • Message 5 of 5

Re: Cannot enable wifi using Fn and F5 keys - Y580

2019-11-03, 1:21 AM

Thank you ! Its working for me too, after reinstalling at my Y580.

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save