Welcome to our peer-to-peer forums, where owners help owners. Need help now? Visit eSupport here.

English Community

Lenovo NotebooksLenovo P, Y and Z series Notebooks
All Forum Topics
Options

2 Posts

01-11-2013

Thessaloniki

1 Signins

21 Page Views

  • Posts: 2
  • Registered: ‎01-11-2013
  • Location: Thessaloniki
  • Views: 21
  • Message 1 of 2

Drivers missing after a Windows 8 Pro x64 UEFI Install on a Lenovo Z580 ideapad

2013-01-11, 7:49 AM

I just formatted and installed.

Drivers missing after a Windows 8 Pro x64 UEFI Install

 

Here is a snapshot:

 

Z580.png

 

 

1) Why Windows UEFI'ed installed couln't be able to detect THOSE 3 DEVICES thus INSTALLING THEIR DRIVERS?

 

2) Windows Legacy Instaled misses not only 3 but 6 devices.

 

3) Last but not least, although identified my wireless card (BroadCom 802.11n) hence Wi-Fi drivers are installed by Win8 themselves, by connection speed is way to slow........

 

HELP and explain please!!

Reply
Options

105 Posts

01-10-2013

Raleigh, NC

62 Signins

1603 Page Views

  • Posts: 105
  • Registered: ‎01-10-2013
  • Location: Raleigh, NC
  • Views: 1603
  • Message 2 of 2

Re: Drivers missing after a Windows 8 Pro x64 UEFI Install on a Lenovo Z580 ideapad

2013-01-12, 1:37 AM

Hello NikosGr,

 

Windows 8 is still a new Operating System, therefore glitches still need to be worked out in future updates.

 

Make sure to go to Lenovo's support website and see if there are any drivers for those devices for Windows 8. Try the Windows 7 drivers too as some of those will work with Windows 8.

 

As for the Broadcom card being slow, they are decent cards, but not the best. I've had issues with mine when I first got my laptop. Hope that helps.

A+ Certified
Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete

X

No, I don’t want to share ideas Yes, I agree to these terms