cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
AntonSilaev
Paper Tape
Posts: 1
Registered: ‎09-12-2019
Location: CA
Views: 246
Message 1 of 1

Fn KEYS ISSUES SOLVED - Y730 but really for most notebooks.

Hi Everyone,

 

I have a Legion Y730.

 

I spent days searching for an answer and was not able to find a solution that worked until now. It seems that this was something that many people had posted about over the years and the solution was very difficult to find if at all.

 

I wanted to share with everyone so that they may find the answer in one place.

 

After reformatting my drive recently and freshly installing Windows 10, my F4, F8, F10-11 secondary functions stopped working. There was no solution anywhere until I saw one post in a random forum that stated that he had Lenovo Utility disabled in his startup and needed it to be enabled for them to work...

 

Low and behold, I found this driver: https://support.lenovo.com/ca/en/downloads/ds500481

 

It is not automatically installed with Lenovo Vantage, or Windows Update, or even DriverEasy (which I have the pro version). Install this, restart, and all of your function keys work once again!

 

I hope this helps whoever is trying to search for a solution to this once and for all!

 

Check out current deals!


Shop current deals

Top Kudoed Authors