cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
clarence2009
Paper Tape
Posts: 2
Registered: ‎11-22-2009
Location: Hong Kong
Views: 1,052
Message 1 of 1

Ideapad Y550 Broadcom Netlink Gigabyte Controller driver problem after upgrading to Windows 7

I recently upgrade my Y550 from Vista to Windows 7. But there is a problem about the LAN driver for the LAN card which is Broadcom Netlink Gigabyte Controller. I just cannot install the driver properly. I had visited the Lenovo Support Website to download the newest driver. But it does not work. The InstallShield had terminated at the end of every installation. I had tried all methods and even visited the Broadcom website to seek help. Still the problem cannot be solved. I can only use WiFi to connect to the network but not LAN card.

 

I find that the problem is not about the LAN driver because if I give up the upgrade and do a clean Windows 7 installation, the LAN driver work. It only cannot work in the upgraded environment. That is very weired for me. I had called the local Lenovo Technical Support Team, the technician cannot solve the problem either.

 

I suspect the Lenevo Technical Department had ever tried to upgrade the IdeaPad Y550 model to Windows 7 to see if all the new drivers are working properly.

 

I had raised this problem in many local computer forums to see if anyone have any idea about this driver problem. Meanwhile, I can only do a clean Windows 7 installation in order to avoid this problem. However, I have to give up all the bundled software in the IdeaPad.

 

It is ridiculous to see that the LAN driver cannot be installed in the upgrade environment.

 

If any reader has similar problem, please share or you may have a solution

 

Check out current deals!


Shop current deals

Top Kudoed Authors