cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
ZoBRE
Paper Tape
Posts: 3
Registered: ‎10-29-2018
Location: IT
Views: 394
Message 1 of 5

Ideapad Z510 - Fan at full speed all the time (even when i'm in BIOS settings)

Hi all , 

i replaced the cooling fan wit a third party one . it runs at full speed all the time (from start/post) and there's no way to speed it down . i've tried with various software for fan control but no one worked . latest bios version and i've already tried to load the default bios settings . even when i'm in the BIOS is at full speed . is there something that i can do to fix this ? there's no software that can show me the fan status.

 

Thank you very much

Social Support Agent
Social Support Agent
Posts: 150
Registered: ‎08-02-2018
Location: PH
Views: 368
Message 2 of 5

Re: Ideapad Z510 - Fan at full speed all the time (even when i'm in BIOS settings)

Hi there! Thanks for posting in our community. Did you have an issue with the fan that came with the laptop reason why you replaced it? If you have already tried updating the bios and still having the same issue, I recommend to contact our service center to have it checked and fixed. Please click https://lnv.gy/2ER042G then filter it by the city nearest you. Thanks. 

 

Mod's Edit: for transparency, shortened link was converted to full URL......

 

https://support.lenovo.com/us/en/solutions/ht118678?Source=social_eservices&Medium=LITHIUM&Term=eSer...

 



Did someone help you today? Press the star on the left to thank them with a Kudo!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"! This will help the rest of the Community with similar issues identify the verified solution and benefit from it.

Follow us @LenovoSupport on Facebook and Twitter!

ZoBRE
Paper Tape
Posts: 3
Registered: ‎10-29-2018
Location: IT
Views: 349
Message 3 of 5

Re: Ideapad Z510 - Fan at full speed all the time (even when i'm in BIOS settings)

The reason i replaced the original fan was because i tried to clean my laptop with compressed air and while i was doing that, fan blades broken badly . So i replaced the fan with one new (fewer blades) .
I have already the latest bios version (8DCN40WW 24/10/2014) . i tried to reset bois settings to default but nothing changed . Any idea ? Nothing works and no software see the fan status .

Thank you for reply and for the assistance links (i found a place near me but i don't want to take the laptop to a service point because is too old to invest money in it , but maybe i'll go to see if they at least heard about this problem)
Highlighted
Social Support Agent
Social Support Agent
Posts: 444
Registered: ‎08-02-2018
Location: US
Views: 346
Message 4 of 5

Re: Ideapad Z510 - Fan at full speed all the time (even when i'm in BIOS settings)


Hi! We highly suggest to use the recommended part number in replacing parts. You can check the part numbers of the fan from this link: https://lnv.gy/2EUy12y, page 87. You can use the part number in buying the part locally or online. Hope this helps.

 

Regards

 

Mod's Edit: for transparency, shortened link was converted to full URL........

 

https://download.lenovo.com/consumer/mobiles_pub/lenovo_z410z510z510touch_hmm.pdf?Source=social_eser...



Did someone help you today? Press the star on the left to thank them with a Kudo!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"! This will help the rest of the Community with similar issues identify the verified solution and benefit from it.

Follow us @LenovoSupport on Facebook and Twitter!

ZoBRE
Paper Tape
Posts: 3
Registered: ‎10-29-2018
Location: IT
Views: 345
Message 5 of 5

Re: Ideapad Z510 - Fan at full speed all the time (even when i'm in BIOS settings)

Thank you very much for the link to the "hardware maintenance manual" , very useful . i bought this one : https://www.amazon.it/gp/product/B073P6LSB8/ref=oh_aui_detailpage_o02_s00?ie=UTF8&psc=1

It seems that the right part number is 90203964 . The one that i bought was same manufacturer (SUNON) but part number DC28000BJS0, AT0T10020S0 . it fits perfectly and the only difference that i can see are the number of blades (half of the original one) and the wire sequence color .

I now searched for the right part number but i only found fans that cost over 50 euros (i'll never spend this much for a piece that has a 2-3$ dollar value and maybe less than a dollar cost price).

i'll try another third party fan . i don't think that there's a microchip on the original one that the motherboard can detect... is just a fan that receive voltage/amperage inputs from the 4 pin connector on the motherboard.

thank you very much for the support . i'll update the post as soon as i fix the problem

Check out current deals!


Shop current deals

Top Kudoed Authors