cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
benm536
Paper Tape
Posts: 1
Registered: ‎09-02-2018
Location: GB
Views: 291
Message 1 of 1

Ideapad Z570 Wifi WONT connect after clean install windows 7 x64 SOLVED

Hello to whoever reading this

 

I hope your day is going better than mine as I’ve experienced issues after re-installing windows on my Lenovo Ideapad Z570 and I have spent 2 days trying to figure it out, but then again that’s probably why your reading this because your also experiencing issues yourself, any way I won’t bore you any longer with more babble so let me get to the point of why I’m writing this

I made this quick post because I also ran in to some trouble when re installing windows after my system had begun to run quite slow.

 

The symptom

The symptom that was present was that after installing windows I just could not get the wireless internet to work for the life of me. It WOULD recognize the driver installed on device manager but just would not pick up any WIFI connections, there was a red cross on the network icon at the bottom right tool tray and when pressing FN+F5 it would not list wireless network card ATALL, only the Bluetooth connectivity icon was present.

 

My procedure

So this was my procedure, I re-installed windows 7 ultimate 64 bit and installed all the drivers accept the wireless LAN driver and the bios update, so that’s including drivers, utilities and software on the off chance that some of the software or utilities also included drivers I needed in the system to work, I tried installing the intel wireless link driver and the wireless LAN drive together, the intel wireless link driver on its own still nothing I even got to the point the I was experiencing the BLUE SCREEN OF DEATH, good thing I created a system image backup file from backup and restore I control panel with everything installed accept the wireless driver, I would highly recommend doing this It saved me loads of time not having to reinstall all the drivers again I could just re image the HHD using a system restore disk I created earlier so yeah I tried so many things to no avail.

HOW I SOLVD MY ISSUE (SO SIMPLE)

So with everything installed I decided 1 last time to try something before I re installed windows again and that was the last thing I hadn’t attempted and that was the bios update, I left this to last resort because I was under the impression that I would have had to carry out a lengthy process in order to flash the bios, as my previous experience with these tasks was pretty long carrying out bios flashes on desktops and what not. So with everything installed I carried out the bios update, which was easy as pie,  it was just a case of downloading the setup and as soon as you opened it, it extracted and then automatically ran and carried out the bios flash (when I say flash it just means rewrite, it deletes the old bios and writes the new bios at the same time) on its own, so when it automatically carried out a system restart I logged in and installed the Wireless LAN drive again and behold the system was able to pick up all the wireless WIFI connections.

 

If anybody has experience this issue this is what I did to fix my laptop, it may not work for everybody but give it a go if you haven’t already updated the bios.

 

All the best and good luck

Check out current deals!


Shop current deals

Top Kudoed Authors