Showing results for 
Search instead for 
Did you mean: 
Paper Tape
Posts: 2
Registered: ‎03-31-2019
Location: US
Views: 323
Message 1 of 2

Ideapad z510 Cannot re-enable touchpad.

So long story short when i got this i was using it as my main computer. Then i got a desktop and forgot about it for a long time.

Now I have revived it and am trying to figure out how to re-enable the touchpad.


Problem being, I used an unusual method off a google search, and five years later I don't remember how I did it.


I am running win 8.1 and according to the computer it is an Alps Touch Pad 8.201.1611.242


I have every enable checkbox under touchpad properties checked. (Still doesn't respond)


I use the f9 + fn buttons to reenable it (Nothing.)


I try to check for it under pointing devices in device manager and I dont see it there. (Not that I know exactly what I am looking for.)

I only have HIP-compliant mouse and Lenovo pointing device, and they are both enabled.

I auto-updated the drivers on both of those and restarted just in case. (Still Nothing)


Does anyone know any OTHER ways of disabling/enabling the touchpad?

Paper Tape
Posts: 2
Registered: ‎03-31-2019
Location: US
Views: 273
Message 2 of 2

Fixed Her

So for the record, I still have no idea what was wrong. 


However, I upgraded my version of Windows 10 to the most recent and it started working again. So.... Yay?

Problem solved. Bit of an extreme solution, but it worked. 

Check out current deals!

Shop current deals

Top Kudoed Authors