cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
thanh3
Paper Tape
Posts: 6
Registered: ‎09-23-2017
Location: DE
Views: 462
Message 1 of 5

Installing mSATA SSD in Y580

So I just installed a Kingston 120GB mSATA SSD SUV500MS in my Y580. I got an HDD with Windows 10 installed on it. But when I turn it on now, it does not get past the Lenovo splash screen. I cannot even load the BIOS. It says Entering SETUP, but nothing happens then.

If I take the SSD out, everything goes back to being normal. Any ideas? Thanks!

LMDidierOrtiz
Punch Card
Posts: 10
Registered: ‎02-13-2013
Location: AR
Views: 324
Message 2 of 5

Re: Installing mSATA SSD in Y580

I have the same problem. Did you find the solution? I hope you did.
thanh3
Paper Tape
Posts: 6
Registered: ‎09-23-2017
Location: DE
Views: 318
Message 3 of 5

Re: Installing mSATA SSD in Y580

Sorry, I have no solution. I ended up sending the SSD back and continuing to my HDD.

But one thing: I rebooted the laptop a couple of times just to test. At some point I was able to get past the splash screen and to access the BIOS and the BIOS recognized the SSD just fine. But when I rebooted again, same problem.

I guess either my mSATA slot or the SSD was broken or some compability issue. If you can get your hands on another mSATA SSD, try it.

LMDidierOrtiz
Punch Card
Posts: 10
Registered: ‎02-13-2013
Location: AR
Views: 313
Message 4 of 5

Re: Installing mSATA SSD in Y580

Ohhh that's bad news.

It's curious that is the same SSD (kingston UV500) and i bought the notebook in DE.

Do you remember if u tried keeping the HDD plugged or not? Also I tried boot using Windows CD and USB.

Thanks for your answer.

thanh3
Paper Tape
Posts: 6
Registered: ‎09-23-2017
Location: DE
Views: 292
Message 5 of 5

Re: Installing mSATA SSD in Y580

I tried both with and without HDD but with the same result.

Check out current deals!


Shop current deals

Top Kudoed Authors