cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
88Charlie
Paper Tape
Posts: 2
Registered: ‎11-04-2014
Location: US
Views: 17,089
Message 1 of 1

Intel Wireless-N 7260 Slow Internet Speed - Solved (Win 8.1 64-bit, Wireless N @ 2.4GHz)

Obviously there are numerous factors that can affect speed. But if you have reason to believe it's just your laptop try the configuration below. Worked for me. Good Luck.

 

Laptop:

Lenovo Ideapad Y510P, Windows 8.1 64-bit.

 

Internet Connection:

Comcast Xfinity Blast advertised at 50Mbps.

 

Network Environment:
Home Wifi, Linksys E1500 Router Wireless N @ 2.4 GHz. Firmware Version: 1.0.06
Apartment Building, ~15 visible other Wifi networks.

Devices with 15 feet of router.

 

Problem Symptoms:

Download speeds of 2-3 Mbps. Upload speeds were typically much higher, around 10Mbps as should be expected.

 

Control Reference:
~50Mbps using ethernet cable.
Older Laptop getting ~45Mbps over Wifi.

 

Solution:

From what I gathered, the problem with the card happens on Wireless N 2.4MHz routers. 

 

Driver version : 17.13.2.2

File : Wireless_17.13.2_De164.zip

Downloaded from : http://goo.gl/S3HOCL (Intel download page. URL was too long to post)

Installation : Unzip to a folder, Run the DPInst64.exe application - does a 'simple' driver install. No Bloatware / fluff.

 

Device Settings: I'm listing only the values that I changed along the way.

Device Manager > Network Adapters > Intel(R) Wireless-N 7260 > Properties > Advanced.

 

802.11n Channel Width for 2.4GHz : Auto

Ad Hoc Qos Mode : WMM Disabled

HT Mode : HT Mode (ie ON. You need this for Wireless N. If Disabled you can only connect to Wireless b/g/mixed)

Roaming Aggressiveness : 1. Lowest

Throughput Booster : Enabled (Not sure if this is necessary. It's an optional feature giving priority over other devices)

Transmit Power : 3. Medium

U-APSD Support : Disabled (According to numerous posts, this is critical)

 

Wireless Router Wireless Settings:

Network Mode : Wireless-N Only

Channel Width : 20 MHz Only. (My only other option is 'Auto (20 MHz or 40 MHz). On 'Auto...' every device I have really slows).

Channel : Auto (I had this set to '3' since day one to avoid the channels other Routers in my building are using. Defintely noticed improvement but it seems its not necessary with this configuration. Could be due to other networks not being used at the time of testing. I'm keeping an eye on this).

 

Bluetooth Network Connection (Personal Area Network):

Disabled

(I have a running bluetooth mouse which is not affected by disabling this)

 

Result:

Testing duration 6 hours, ~ 10 times.

http://speedtest.comcast.net/ 

 

For the settings. most likely there's some that are not necessary. But after working on this for 3 days, I'm not changing anything for the time being.

 

Blurb: 

I'm posting this to hopefully help others who have this issue. Researching the problem I found numerous lengthy fourm threads filled with frustrated users...one on Intel's support site was 18 pages long with literally months of posts with several users discussing a class action lawsuit...enough said.

 

I tried pretty much all the posted solutions, lots of different driver versions, device settings, router settings. There's so much misinformation out there it's not funny. Eventually I called Lenovo Tech Support who tried simialr things and momentarily got it a bit better and wanted to say it was fixed. I hung on a kept testing the slow speed soon returned. Then they tried all the usual nonsense and excuses and gave up, passing me off to "Premium Support:" who wanted to charge me to investigate the problem. The "premium" techs were really poor and sounded like a bunch of clueless hacks just trying to get you to pay for the service while simultaneously throwing in gems like "how far is your laptop from the router...that can affect your speed"...anyway, forget that I thought.
 
When I first got the Lenovo Ideapad Y510P last year I had the same or similar issue. I don't recall how I fixed it then but I got it to ~20-30Mbps. While well below my older laptop's speed it was perfectly adequate. That was last August. Earlier this year there was an update for Intels stuff in a Windows update. I think the problem started again with that although I'm not 100% sure. Certainly I didn't manually install new drivers or change anything on my network set-up.

Check out current deals!


Shop current deals

Top Kudoed Authors