cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
MEHRADSYS
SCSI Port
Posts: 104
Registered: ‎05-23-2013
Location: UNITED STATES
Views: 19,729
Message 1 of 5

Kernel-pnp (PLEASE HELP)

I have following error message on Event Viewer\Windows \System:

The driver \Driver\WUDFRd failed to load for the device ROOT\LENOVOVHID\0000.

 Untitled.png

What is it?

Can i fix them?

Thank you before.

ideapad Y480: Intel Core i7-3610QM 2.30GHz, 6.00GB RAM
Intel HD Graphics 4000 + Nvidia Geforce GT640m LE
750GB HDD, Dual Boot: Win8.1 Pro with MC 64bit and Win7 Ultimate 64bit
Social Support Agent
Social Support Agent
Posts: 5,822
Registered: ‎02-11-2012
Location: PH
Views: 19,633
Message 2 of 5

Re: Kernel-pnp (PLEASE HELP)

hi MEHRADSYS,

 

The WUDFRd seems to be related to the service Windows Driver Foundation - User-mode Driver Framework.which controls a device driver to restart everytime a device is plugged-in (i.e. USB device) - more info here.

 

If you get the error after plugging-in a USB device on startup then the issue might be similar to this thead.

 

The fix was to:

1. Open services.msc (press Windows key+R > type services.msc)

2. Look for Windows Driver Foundation - User-mode Driver Framework on the list of services and ensure the Startup Type is Automatic and Status is Started.

3. Try to reboot the computer and observe if you still get any errors.

 

 

Let me know your findings

 

Regards



Did someone help you today? Press the star on the left to thank them with a Kudo!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"! This will help the rest of the Community with similar issues identify the verified solution and benefit from it.

Follow us @LenovoSupport on Facebook and Twitter!

skeefiez11
Paper Tape
Posts: 3
Registered: ‎06-03-2016
Location: US
Views: 12,760
Message 3 of 5

Re: Kernel-pnp (PLEASE HELP)

Hi. I too am having the same error:

 

The driver \Driver\WUDFRd failed to load for the device ROOT\SYSTEM\0001

 

I have a Lenovo H50 Desktop (Win 10) and last night or early this morning something happened to my PC as when I went to use it, I did see the power light still on (screen was in power saver mode, but when I clicked on any key or on the mouse, nothing was happening and the PC was apparantly unresponsive (or in some sort of "hibernation") and I had to basically hold down the power button until the PC shut off. I then powered it back on but still nothing happened. So, before I started to freak out (I got this PC in December so not that long ago), I again held down the power button to force shutoff then I unplugged the PC for a minute or two, then plugged back in and powered the PC back on. At least this time it booted up, but it seemed to come up to the "lock screen" rather than the usual main login screen - again as if it was in some sort of strange sleep or hibernation mode with someone logged in.. I then confirmed this by choosing to restart the system and it did give a warning that some users may lose information..blah blah, but I chose to do the fresh restart anyway. After the restart, it booted up normally to the main login screen.  I did look in the event viewer but did NOT see any Critical events in the past hr or 24 hrs, a few Errors (none that I could see that explained the freeze) but saw these Warnings:

 

Capture1-warning219.JPG

Is something occasionally freezing my PC while in sleep mode?  Please advise or let me know what else is needed? Thanks

RustyArmour
What's DOS?
Posts: 1
Registered: ‎08-12-2016
Location: US
Views: 12,242
Message 4 of 5

Re: Kernel-pnp (PLEASE HELP)

I would also really like to know what the fix is for this. This is a brand new system and I've already spent a full day updating drivers and fixing errors. So far, this is way beyond what should be required to setup a new system. I am not at all happy about it either.

 

Log Name: System
Source: Microsoft-Windows-Kernel-PnP
Date: 8/12/2016 3:19:40 AM
Event ID: 219
Task Category: (212)
Level: Warning
Keywords:
User: SYSTEM
Computer: newTWKdesktop
Description:
The driver \Driver\WUDFRd failed to load for the device ROOT\SYSTEM\0001.
Event Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
<System>
<Provider Name="Microsoft-Windows-Kernel-PnP" Guid="{9C205A39-1250-487D-ABD7-E831C6290539}" />
<EventID>219</EventID>
<Version>0</Version>
<Level>3</Level>
<Task>212</Task>
<Opcode>0</Opcode>
<Keywords>0x8000000000000000</Keywords>
<TimeCreated SystemTime="2016-08-12T07:19:40.951395000Z" />
<EventRecordID>2964</EventRecordID>
<Correlation />
<Execution ProcessID="4" ThreadID="216" />
<Channel>System</Channel>
<Computer>newTWKdesktop</Computer>
<Security UserID="S-1-5-18" />
</System>
<EventData>
<Data Name="DriverNameLength">16</Data>
<Data Name="DriverName">ROOT\SYSTEM\0001</Data>
<Data Name="Status">3221226341</Data>
<Data Name="FailureNameLength">14</Data>
<Data Name="FailureName">\Driver\WUDFRd</Data>
<Data Name="Version">0</Data>
</EventData>
</Event>

ThinkErEr
Punch Card
Posts: 9
Registered: ‎02-25-2017
Location: SE
Views: 9,212
Message 5 of 5

Re: Kernel-pnp (PLEASE HELP)

Sorry, don't have a fix for you, but have managed to trace down the origin of the Warning message.

 

The message seems to relate to an installed driver/software packagage, i.e. the Lenovo System Interface Foundation. In my case the version is 1.0.76.0 (Windows 10 Pro, Version 10.0.14393 Build 14393).

 

(See the Drivers & Software download list at Lenovo Support, i.e. support.lenovo.com, for your specific machine).

 

You can verify this by, downloading the most recent version of this driver, uninstalling the currently installed driver, reboot, check System Log -> Warning Message is GONE, reinstall downloaded driver, reboot, check System Log -> Warning Message is BACK.

 

Registry Key is: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum\ROOT\SYSTEM\0001


Best regards // ThinkErEr

ThinkCentre M900 Tiny, i7, 16GB, Samsung 950 PRO M.2 NVMe 512GB

Check out current deals!


Shop current deals

Top Kudoed Authors