Welcome to our peer-to-peer forums, where owners help owners. Need help now? Visit eSupport here.

English Community

Lenovo NotebooksLenovo P, Y and Z series Notebooks
All Forum Topics
Options

4 Posts

04-12-2016

UK

10 Signins

55 Page Views

  • Posts: 4
  • Registered: ‎04-12-2016
  • Location: UK
  • Views: 55
  • Message 1 of 1

Lenovo Ideapad z580 Bios & boot issues (windows 10 64 bit)

2016-04-12, 19:34 PM

Lenovo Ideapad z580 Win10 64

 

I updated the bios with the private update (I know now that I should have used the public update)

 

Then it showed this menu:

http://i.imgur.com/kZaO2tf.jpg

 

Whenever I selected HDD, the screen would go black for a couple of seconds and return to this menu.

 

I fixed it by going into BIOS and changing bootmode from UEFI to Legacy. it booted but now everything is slow. It takes 5 mins to boot up and a further 15 minutes to reach usable speeds (I only have 4 startup programs). I tried changing it back to UEFI and it gives me the same problem as shown in the picture.

 

I tried installing the public update, but it says that I cannot update as the current bios version is the same or newer.

 

I went into BIOS and enabled BIOS back flash, and now when I try to start the public update, it just crashes.

 

I also cannot access the start menu (this problem may be seperate and unrelated)

 

I have backed up files and am prepared to do a clean reinstall of Win10, but I feel this won't work as it's a BIOS issue.

 

The computer is unusably slow: what should I do?

 

Thanks

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete

X

No, I don’t want to share ideas Yes, I agree to these terms