cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Michat
Fanfold Paper
Posts: 1
Registered: ‎06-28-2017
Location: FR
Views: 467
Message 1 of 2

Lenovo P50 - Biometric device stopped working - Windows 10 Creators Update

Hello everyone,

 

Since monday I have some problems with fingerprint authentication via Windows Hello. It seems to have stopped working for some reasons I don't know.

 

At the beginning, I thought it was a hardware issue but it doesn't seems to be. I'll explain why.

 

Problem description:

 

 

When I try to authenticate via fingerprint, OS redirects me to PIN authentication automatically.

So I removed my saved fingerprint and tried to set the same fingerprint (and others). But now I can't add a new fingerprint, Windows Hello seems to be inert. My fingerprint device doesn't work.

When I removed my PIN and retried to set a fingerprint, my fingerprint device works and detects my finger. Then I've added a new PIN to enable Windows Hello. But neither my PIN nor my fingerprint was saved. 

 

Attempts to fix the problem:

 

- I tried to update driver, I have the last one (5.1.324.26). I tried to uninstall it then reboot, nothing happens;

- Via administrative templates, try to enable it on Windows Components, nothing happens;

- Reset fingerprint settings into BIOS/ Security then F10, nothing happens;

- Tried to recover Windows with keeping files, nothing happens.

 

I've made some snapshots of what I'm explaining :

 1. set with PIN.PNGClick on Set up fingerprint. Set with PIN already registered. I just have a cancel button and nothing else.2. set fingerprint.PNGRemoved PIN before. Fingerprint device works3. set PIN.PNGAdd New PIN4. nothing....PNGBut nothing was saved...

 

I'm totally confused. I think it's a software problem, in particular with Windows Hello.

What do you think?

 

Thanks for advice!

orangehuang
Punch Card
Posts: 18
Registered: ‎10-28-2009
Location: CHN
Views: 382
Message 2 of 2

Re: Lenovo P50 - Biometric device stopped working - Windows 10 Creators Update

Michat,

 

I ever saw the similar problem. But I can't recall clearly how it was resolved.
You may try two ways on your machine:

 

1) Create another local user account and then try to set up PIN and Fingerprint on that new account.

 

2) Go to BIOS to clear TPM once. Note if you're using TPM chip to encrypt some files specially, please take care of it.

Check out current deals!


Shop current deals

Top Kudoed Authors