cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
LeowSx
Fanfold Paper
Posts: 4
Registered: ‎09-14-2017
Location: JP
Views: 1,279
Message 1 of 7

Lenovo Y400 WIndows 10 Intel HD Driver(Microsoft Basic Display Adapter) missing in Device Manager

I have updated my windows 8.1 to Windows 10 . But my intel HD graphics driver/Microsoft Basic Display Adapter is missing in the DeviceManager. How can I enable again the driver for using 3 displays(2 external monitors)?


I have search for BIOS but the BIOS seems like doesn't have the option to choose Nvidia Optimus for switchable Display adapter.

 

here is my Computer Specs and the Device Manager.
specs.PNGspecs2.PNG
I have tried to downlaod the Intel VGA driver from Lenovo IdeaPad Y400 page. But it shows this error.

specs3.PNG

 

Does anyone can help me please?

Retired Support Specialist
Posts: 182
Registered: ‎07-19-2017
Location: IN
Views: 1,243
Message 2 of 7

Re: Lenovo Y400 WIndows 10 Intel HD Driver(Microsoft Basic Display Adapter) missing in Device Manage

Hi LeowSx,

 

Thank you for the reply.

 

This type of error shows up when the driver and the OS version don't match.

Example: you cannot install a 64-bit driver on a 32-bit Operation System

To identify which bit of OS is installed on your unit, Go to Control Panel > Systems and Security > System. Under System, the system type is either a 64-bit or 32-bit OS

And the Drivers available on the Lenovo support center is for the 64 bit.

 

Hope the above information helps and please let us know how you go about.

 

Please feel free to post in Lenovo Community Forums if you have any further queries!

 

Regards,

Rameez

 

Tap that kudos button if I helped.
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"!

LeowSx
Fanfold Paper
Posts: 4
Registered: ‎09-14-2017
Location: JP
Views: 1,236
Message 3 of 7

Re: Lenovo Y400 WIndows 10 Intel HD Driver(Microsoft Basic Display Adapter) missing in Device Manage

Thank you for reply!

As the photo I shown in previous post, I know that I have a Windows 10 Home 64bit.

Therefore, I download Intel VGA Driver for Windows 10 (64-bit) - Notebook from https://pcsupport.lenovo.com/jp/en/products/laptops-and-netbooks/ideapad-y-series-laptops/ideapad-y4... .

 

It just show the error . Is there any another way to solve this problem?

LeowSx
Fanfold Paper
Posts: 4
Registered: ‎09-14-2017
Location: JP
Views: 1,198
Message 4 of 7

Re: Lenovo Y400 WIndows 10 Intel HD Driver(Microsoft Basic Display Adapter) missing in Device Manage

I wondering lenovo y400 can have a windows 10  bios update to get the Nvidia Optimus available?

my y400 just don't have the option of Nvidia Optimus to do the automatic GPU switching.

 

Is that possible?

Highlighted
Retired Support Specialist
Posts: 182
Registered: ‎07-19-2017
Location: IN
Views: 1,167
Message 5 of 7

Re: Lenovo Y400 WIndows 10 Intel HD Driver(Microsoft Basic Display Adapter) missing in Device Manage

Hi LeowSx,

 

Thank you for the reply

 

I am sorry that the issue is not resolved however you can follow these steps and see if it works.

1.In Device Manager, in the Action menu, click Scan for hardware changes.

2.Follow the instructions on the screen.

You can also manually add the device following the steps:

1.Open Device Manager.

2.Right-click the top node in the details pane.

3.Click Add legacy hardware.

4.In the Add Hardware Wizard, click Next, and then follow the instructions on your screen.

If the above steps doesn’t work please contact the service center for the further TS

Hope the above information helps and please let us know how you go about.

 

Please feel free to post in Lenovo Community Forums if you have any further queries!

 

Regards,

Rameez

LeowSx
Fanfold Paper
Posts: 4
Registered: ‎09-14-2017
Location: JP
Views: 1,161
Message 6 of 7

Re: Lenovo Y400 WIndows 10 Intel HD Driver(Microsoft Basic Display Adapter) missing in Device Manage

I have tried the method you tried, when I try to install the legacy driver (Microsoft Basic Display Adapter(No ACPI support)), it shows this error.

specs4.PNG

 

I have no idea with this. It my registries or some system parameters got problem?

Retired Support Specialist
Posts: 182
Registered: ‎07-19-2017
Location: IN
Views: 1,155
Message 7 of 7

Re: Lenovo Y400 WIndows 10 Intel HD Driver(Microsoft Basic Display Adapter) missing in Device Manage

Hi Leowsx,

 

Thank you for the reply.

 

Looks like the issue might be with the registry permissions, Here’s what you can do

Click on Start on your desktop. Type Regedit press enter. Find the device you just installed - probably under PCI (if you click on each device to expand the folder and then click on the contents you should eventually find the right one by reading the description on the right column). Once you've found it Right Click on the folder the device is in in the left column- click permissions - make sure everything is set to Allow close Regedit and try to run your software.

 

Warning Serious problems might occur if you modify the registry incorrectly by using Registry Editor or by using another method. These problems might require that you reinstall your operating system. we cannot guarantee that these problems can be solved. Modify the registry at your own risk.

 

Hope the above information helps and please let us know how you go about.

 

Please feel free to post in Lenovo Community Forums if you have any further queries!

 

Regards,

Rameez

 

Tap that kudos button if I helped.
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"!

Check out current deals!


Shop current deals

Top Kudoed Authors