English Community

Lenovo NotebooksLenovo P, Y and Z series Notebooks
All Forum Topics
Options

1 Posts

08-25-2017

GB

2 Signins

45 Page Views

  • Posts: 1
  • Registered: ‎08-25-2017
  • Location: GB
  • Views: 45
  • Message 1 of 5

Lenovo Y50-70 Not Charging

2017-08-25, 13:20 PM

Whenever i plug my charger in, it says charging for a second, then reverts back to the battery. It used to only charge when it was off, so id have to shut down to get a full charge, then turn it on, use that power then shut down again and repeat. Now though, it wont charge at all, even when off.

 

The battery doesnt seem to be the problem because the laptop turns on for a second when the battery is unplugged.

 

The charger is working fine it seems as it is throwing out the correct voltage according to my multimeter.

 

The AC Jack has been replaced also but the problem persists. The charging pins on the part the AC Jack plugs in to the motherboard has the correct voltage on my multimeter also, so it cant be that.

 

This leaves me lost. Any suggestions would be greatly appreciated, I need this laptop for Uni work :(

 

When switched off, I plug in the charger and get an orange flashing battery light for a few seconds. It then switches to solid orange battery light and a solid white power light. It seems to be switching itself on and wasting any battery it had? Atleast thats what I can tell from the light guide I found. Although the screen and keyblard light don’t turn on when this happens. I dont know. They do turn on when the power button is pressed though for a split second before it shuts itself off.

 

Sorry if this makes no sense, i’m just trying to provide as much info as I can.

Reply
Options

2953 Posts

02-22-2017

GB

1083 Signins

26243 Page Views

  • Posts: 2953
  • Registered: ‎02-22-2017
  • Location: GB
  • Views: 26243
  • Message 2 of 5

Re: Lenovo Y50-70 Not Charging

2017-08-29, 11:44 AM

Hello Jaymeetee

Thanks for using the Lenovo forums.


I would say try to see if you are able to use another charge, just in case.

 

Also, Try a static discharge for this, it may help to resolve the issue or at least get rid of any built up static on the motherboard.

(If the battery is internal, please just skip the remove/replace battery steps.)
1. Turn the unit off
2. Remove the battery and the Mains adapter
3. Press and hold the front power button for 30 seconds
4. Replace the battery and the Mains adapter
5. Turn the unit on as normal

Hope this helps, let us know how you get on.


==================================================================================
Did someone help you today? Thank them with a Kudo!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"!

 

This will help the rest of the Community with similar issues identify the verified solution and benefit from it.




Pesszimistának lenni a legjobb, vagy igazad van, vagy kellemesen meglepődsz...
Reply
Options

1 Posts

11-28-2018

US

2 Signins

14 Page Views

  • Posts: 1
  • Registered: ‎11-28-2018
  • Location: US
  • Views: 14
  • Message 3 of 5

Re: Lenovo Y50-70 Not Charging

2018-11-28, 4:38 AM

I solve this by removig the central pin of charger in a Lenovo y50 70, dont know why, but work.

 

https://h30467.www3.hp.com/t5/Hardware-para-notebooks/LAPTOP-ENCENDIDO-NO-RECIBE-CARGA-DE-AC-quot-SOLO-APAGADO/td-p/718479/page/2

Reply
Options

1 Posts

10-01-2019

US

6 Signins

21 Page Views

  • Posts: 1
  • Registered: ‎10-01-2019
  • Location: US
  • Views: 21
  • Message 4 of 5

Re: Lenovo Y50-70 Not Charging

2019-10-02, 1:09 AM

Ibahim - Hola. Do you have a picture of the pin in the power connector that needs to be removed?

Thanks/gracias

Ramon

Reply
Options

1 Posts

05-01-2020

GB

3 Signins

15 Page Views

  • Posts: 1
  • Registered: ‎05-01-2020
  • Location: GB
  • Views: 15
  • Message 5 of 5

Re:Lenovo Y50-70 Not Charging

2020-05-01, 11:09 AM

Hi there!  I have a Lenovo-Y50-70 that's also not charging.  I bought a replacement power cable and tried it, but no success.  When I connect the new charging cable, I get nothing at all, no lights or anything.  I've left it overnight and still nothing.

 

Before it completely stopped working, it seemed like the battery wasn't charging (which is why I decided to try a new cable) and it seemed to have just enough juice in the battery to start booting up but it would die a few seconds into start up.  Ie, the lights would turn on when you pressed the power on button, the screen would start up, and then it would all die)

 

Given the fact that no lights are coming on at all even with a new cable, I guess that probably (although not 100% sure) counts out the battery being completely dead, although it was certainly getting towards end of life warning status.  Does having no lights even when plugged in also tie in with the possibility of static discharge being a possible solution, or would you expect at least to have lights when the machine is plugged in (but not powered up)?

 

Thank you! 

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete