Showing results for 
Search instead for 
Did you mean: 
Fanfold Paper
Posts: 1
Registered: ‎08-22-2018
Location: SK
Views: 565
Message 1 of 2

Lenovo Y50-70: Stuck on lenovo logo, then boot



I have 3 year old Lenovo Y50-70 laptop. Couple days ago i decided to finally upgrade to SSD. 

The old HDD was 1TB WD 10SPCX and i replaced it with 480GB Kingston UV500 SSD.


When I swapped the drives and tried to boot, I was stuck on completely black screen with only Lenovo logo. This ocured when I tried to enter Novo menu using Lenovo Novo button as well. I tried to put back the old HDD and it was working normally. When i pulled out both disks and tried to boot only from bootable USB this problem did not occur.


Then i tried to plug the SSD to some HP desktop computer and I was able to install windows there and boot on the desktop normally. So I put the SSD back into my laptop and again i was stuck on the logo. However, because Windows was now installed, I was able to boot after being stuck on the Lenovo logo for some time. Then I tried to change the SATA controller mode. I tried both Compatible (IDE) and AHCI modes and installed fresh windows using both settings but still I was stuck on the cursed Lenovo logo. The lag lasted ~1 minute when usind the IDE and 6-7 minutes using AHCI setting. 


My bios version is the same as the version available for donwload on my laptop drivers page (V3.03). Using bios options to restore to defaults or OS optimized defaults did not make any difference. All the drivers are installed and up to date, though I think this is irrelevant as the problem first occured before any OS was present. 


Could it be that the SSD is not compatible with my motherboard?

What's DOS?
Posts: 1
Registered: ‎08-27-2018
Location: FI
Views: 498
Message 2 of 2

Re: Lenovo Y50-70: Stuck on lenovo logo, then boot

I Have exactly the same issue: same laptop model and same SSD.


Old HDD drive is working fine, but if i install the SSD i cannot post/boot at all: novo menu or BIOS access are not working.


I have tried pretty much everything that you have, but nothing seems to work.


Have you made any progress with the issue?


Check out current deals!

Shop current deals

Top Kudoed Authors