Showing results for 
Search instead for 
Do you mean 
Reply
Paper Tape
Posts: 2
Registered: ‎04-01-2017
Location: DE
Message 1 of 10 (832 Views)

Lenovo Y50-70 doesn't boot

[ Edited ]

Dear Lenovo community, please try to help to solve the following problem:

  • I have Windows 8.1 OS
  • After recent update and restart my computer I got this problem - it's not booting up
  • After pushing power button it starts as normal (fans, lights) but I have black screen 📺 
  • It stays like working with proper fans noice but display is black
  • BIOS mode doesn't boot either with small button, this I don't understand why bios is not working neither...
  • I try to power off and start again - the same situation
  • Indicator of hard disk on the front panel is blinking with constant tempo
  •  IMG_0058.JPG
  • I have this problem since one week and sometimes laptop starts booting as normal after like 5-10 mins waiting with the black screen; and then works normal; when I send him to sleep it's also no problem to wake him up but when I reboot or shut down problem comes back
  • sometimes I can keep him running after start like half an hour but it's not booting, then I shut him down and start again, and maybe again. This can start working like randomly...
  • today I tried to install windows again but after restart it's not booting again.

 

What this could be? What can I do? If this is the problem of hard disk, then at least bios would start normally... or it's a problem of motherboard?

 

Thank you in advance for your support!

Token Ring
Posts: 44
Registered: ‎10-19-2015
Location: IQ
Message 2 of 10 (778 Views)

Re: Lenovo Y50-70 doesn't boot

[ Edited ]

Remove that Ethernet cable and try to boot to bios -
I had issue like that but when it was running and left few mins it was not waking up until i force shutdown it , however this looks like same problem that E540 had.
try with one ram if you can open the back . my problem was driver conflict .

Paper Tape
Posts: 2
Registered: ‎04-01-2017
Location: DE
Message 3 of 10 (769 Views)

Re: Lenovo Y50-70 doesn't boot

[ Edited ]

Hello Zhiar,

 

thanks for hints.

 

Actually I have no Ethernet connection, always use wifi for internet.

 

I also tried with one ram - doesn't work neither:

IMG_0062.JPG

 

How can I take out the data from hard disk? Some special adapter, right? Is it 2.5"?

 

I really don't know what to do...

Token Ring
Posts: 44
Registered: ‎10-19-2015
Location: IQ
Message 4 of 10 (752 Views)

Re: Lenovo Y50-70 doesn't boot

sorry for late reply , i was off all day,
you ether buy sata to usb cable , comes cheap (9 bucks)
or you can take harddrive out and put it in another laptop -it will boot just fine -just without drivers so you will be able to access your data I think you need to tun off legacy boot on the laptop .

Token Ring
Posts: 44
Registered: ‎10-19-2015
Location: IQ
Message 5 of 10 (751 Views)

Re: Lenovo Y50-70 doesn't boot

please do one last try - one ram
unplug battery cable to mobo
old power button for 30 seconds-plug in battery ,try to boot ,GL .
Paper Tape
Posts: 1
Registered: ‎06-20-2017
Location: AT
Message 6 of 10 (676 Views)

Re: Lenovo Y50-70 doesn't boot

I have the same problem with Windows 10 and BIOS at V1.14 Rev 3.7.

 

With only one 8GB RAM I cannot try removing one. Was there any solution from the guy who started the Topic?

 

Rgds

What's DOS?
Posts: 1
Registered: ‎10-09-2017
Location: PT
Message 7 of 10 (495 Views)

Re: Lenovo Y50-70 doesn't boot

BIOS intalation maybe corrupted, had exactly the same problem, installed the bios update and it was resolved, but it was very difficult because to install it I had to rely on the pc randomly booting. But then after trying sometimes it worked! Everything is fine now

 

Blue Screen Again
Posts: 2
Registered: ‎03-16-2015
Location: DE
Message 8 of 10 (324 Views)

Re: Lenovo Y50-70 doesn't boot

[ Edited ]

I have the same problem. But I also noticed a clicking sound from my internal speakers. It's more of a loud popping sound if I connect external speakers. The problem started some weeks ago, but normally it only took a few seconds and clicks/pops and the BIOS screen came up. When the system finally started everything was working normally.

 

I hope I can somehow get it to start again so I can update the BIOS if that really fixes the problem...

Paper Tape
Posts: 1
Registered: ‎11-01-2017
Location: US
Message 9 of 10 (287 Views)

Re: Lenovo Y50-70 doesn't boot

I can not boot up and the computer makes alert beeping sound when plug in and out the charger (includig directly to the wall socket). I have tried removing the battery, still wouldn't boot up.  Please help!! thanks

Paper Tape
Posts: 23
Registered: ‎01-10-2018
Location: ZA
Message 10 of 10 (71 Views)

Re: Lenovo Y50-70 doesn't boot

Hey buddy I have the same problem at the moment.

It seems it is version 3.03 of the BIOS.

Put the laptop in the freezer for 10-15 min and take it out and it will turn on.

(it many take up to a few minutes, but it does)

revert the bios back to version 3.  I am having an issue where it wont revert.

(remember to turn on backward flashing in the BIOS)

Smiley Wink

Top kudoed Authors