English Community

Lenovo NotebooksLenovo P, Y and Z series Notebooks
All Forum Topics
Options

1 Posts

01-27-2019

IT

13 Signins

33 Page Views

  • Posts: 1
  • Registered: ‎01-27-2019
  • Location: IT
  • Views: 33
  • Message 1 of 3

Lenovo Y50-70 - some keys not working

2019-01-27, 12:20 PM

Hi all I have a problem that is driving me crazy with the keyboard of my Lenovo Y50-70 laptop.

 

Substantially a series of keys does not work: Z a q 1 esc and |.

 

I can not figure out whether it is a problem in hardware or software but I prefer more for the second, because when I followed some tutorials on YouTube related to the deactivation and activation of keyboard filters to solve the problems related to it, sometimes seems to solve the problem but soon the keyboard returns to not work. I've recently installed Windows 10 on my new SSD, although the problem has persisted since before it was installed.

 

Sometimes the keyboard returns to work in the most unthinkable moments, so suddenly, without a logic although I have noticed that sometimes it seems to work when the laptop battery is almost empty but I do not know if it's a coincidence. I work with the computer and I am also writing the master thesis and it is therefore essential that it works and I would like to avoid buying another keyboard, especially for a few keys, if the problem can be solved at the software level. I also tried changing the keyboard from IT to EN and back to IT and it worked for a while and then resumed.

 

I tried an Ubuntu Live and it all works, and I'll tell you more. I also tried changing the keyboard from IT to EN and back to it.

after starting Ubuntu, it worked on Windows for an entire morning. After a while, however, he resumed, and now it does not work anymore also on Ubuntu.

All the drivers are updated.

 

I have no idea what it could be. How can I solve?

Reply
Options

1 Posts

02-11-2019

US

4 Signins

48 Page Views

  • Posts: 1
  • Registered: ‎02-11-2019
  • Location: US
  • Views: 48
  • Message 2 of 3

Re: Lenovo Y50-70 - some keys not working

2019-02-11, 22:18 PM

I am having a similar/same issue on my Y520 with the 'e', 'g', 'h', and '8' (on the number pad).

 

Sometimes, the keys work fine. Other times they are completely unresponsive, and then there are times they are hyper-responsive. E.g. a single key press will result in "eeeee", "gg", "hhh", and thus strange phrases like "HHHHi thhheeeeeree". 

I've tried the suggestion from an earlier thread of hard rebooting, but this never seems to work as the problem has been ongoing?

 

Any help would be greatly appreciated. Thanks.

Reply
Options

0 Posts

02-08-2020

US

0 Signins

0 Page Views

  • Posts: 0
  • Registered: ‎02-08-2020
  • Location: US
  • Views: 0
  • Message 3 of 3

Re: Lenovo Y50-70 - some keys not working

2020-02-08, 12:23 PM

I have the same problem with the left side of the keyboard and no solution ?‍♂️ I am starting to notice they stop working more often with time.

From what I see you also cannot just replace the keyboard, but have to replace the entire armrest

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save