English Community

Lenovo NotebooksLenovo P, Y and Z series Notebooks
All Forum Topics
Options

1 Posts

10-14-2018

NL

1 Signins

6 Page Views

  • Posts: 1
  • Registered: ‎10-14-2018
  • Location: NL
  • Views: 6
  • Message 1 of 3

Lenovo Y500 no working bluetooth drivers

2018-10-14, 0:40 AM

Hello,

 

I'm trying to install the official bluetooth drivers for Windows 10 for my Lenovo Y500from the Lenovo website. But when I try to install it I get a compability error. I can't seem to find any other drivers online that are suitable for my Y500. Does anybody else have this problem? I hope someone can help me out 

Reply
Options

601 Posts

08-01-2018

US

390 Signins

10360 Page Views

  • Posts: 601
  • Registered: ‎08-01-2018
  • Location: US
  • Views: 10360
  • Message 2 of 3

Re: Lenovo Y500 no working bluetooth drivers

2018-10-14, 7:48 AM

Hi RSlippens!

 

Welcome to our Community Forums!

 

Have you checked the Hardware model of the Bluetooth device on your Y500?

Here's the default drivers from our website :

Broadcomm/Atheros https://pcsupport.lenovo.com/us/en/products/LAPTOPS-AND-NETBOOKS/IDEAPAD-Y-SERIES-LAPTOPS/IDEAPAD-Y500-NOTEBOOK/downloads/DS104130

 

Inter https://pcsupport.lenovo.com/us/en/products/LAPTOPS-AND-NETBOOKS/IDEAPAD-Y-SERIES-LAPTOPS/IDEAPAD-Y500-NOTEBOOK/downloads/DS032604

Regards,



Did someone help you today? Press the star on the left to thank them with a Kudo!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"! This will help the rest of the Community with similar issues identify the verified solution and benefit from it.

Follow us @LenovoSupport on Facebook and Twitter!

Reply
Options

1 Posts

05-10-2019

HU

2 Signins

32 Page Views

  • Posts: 1
  • Registered: ‎05-10-2019
  • Location: HU
  • Views: 32
  • Message 3 of 3

Re: Lenovo Y500 no working bluetooth drivers

2019-05-10, 21:04 PM

Hi,

I just reinstalled my complette OS.

With a fresh win10 64, and official drivers from Lenovo Installed I had the same issue.

I uninstalled the two Atheros drivers from progarams + restart.

Got Bluetooth working.

GL 

 

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save