English Community

Lenovo NotebooksLenovo P, Y and Z series Notebooks
All Forum Topics
Options

4 Posts

06-06-2018

PL

12 Signins

68 Page Views

  • Posts: 4
  • Registered: ‎06-06-2018
  • Location: PL
  • Views: 68
  • Message 1 of 8

Lenovo Y510P SLI malfunction

2018-06-06, 6:50 AM

Hi all !

This is my first post, honestly I lost hope to find something in Google and I really need your help.
First of all my Notebook spec:

Lenovo Y510P

Intel Core I5 4200M
8 GB RAM DDR3 (Dual channel)
2x GT 750M (no overclock or sth)
Windows 10 actual version
Graphic Driver actual version (Installed via GeForce experience)

For some time (no idea it happened after Windows or GeForce driver update) after I turn on any game (World of Tanks, Fallout 4, Witcher 3, Frostpunk) there are dramatical graphic errors.

Print screen attached.

Does anyone had similar problem ?

Solved! See the solution
Reply
Options

50 Posts

12-17-2015

US

213 Signins

1551 Page Views

  • Posts: 50
  • Registered: ‎12-17-2015
  • Location: US
  • Views: 1551
  • Message 2 of 8

Re: Lenovo Y510P SLI malfunction

2018-06-07, 1:56 AM
Go to Geforce Experience and check which driver version you're running.
y410p - Windows 10 x64 | i7-4700MQ | 16GB RAM |GT 755M SLI| 512GB ZTC M.2 |
3DMark: 4228 - http://www.3dmark.com/fs/7029653
Reply
Options

4 Posts

06-06-2018

PL

12 Signins

68 Page Views

  • Posts: 4
  • Registered: ‎06-06-2018
  • Location: PL
  • Views: 68
  • Message 3 of 8

Re: Lenovo Y510P SLI malfunction

2018-06-07, 6:19 AM
Windows 10 Home (compilation 17134.48)
Drivers WHQL Game Ready driver 398.11.
I tried to install older version of driver, but during system check I got information that drivers are not related to system version. I also cant make a rollback from Windows device manager.
Reply
Options

50 Posts

12-17-2015

US

213 Signins

1551 Page Views

  • Posts: 50
  • Registered: ‎12-17-2015
  • Location: US
  • Views: 1551
  • Message 4 of 8

Re: Lenovo Y510P SLI malfunction

2018-06-07, 20:39 PM
Well the first thing you can try doing is installing the hotfix for driver 398.11: http://nvidia.custhelp.com/app/answers/detail/a_id/4678

Also do you use DDU before installing a new driver?
y410p - Windows 10 x64 | i7-4700MQ | 16GB RAM |GT 755M SLI| 512GB ZTC M.2 |
3DMark: 4228 - http://www.3dmark.com/fs/7029653

0 person found this solution to be helpful.

This helped me too

Reply
Options

4 Posts

06-06-2018

PL

12 Signins

68 Page Views

  • Posts: 4
  • Registered: ‎06-06-2018
  • Location: PL
  • Views: 68
  • Message 5 of 8

Re: Lenovo Y510P SLI malfunction

2018-06-10, 21:13 PM

Well, I installed driver HotFix and reboot PC. After that I turned on Fallout 4 and game was working fine... for 30 seconds. After that I saw same image as before. So overhating looks like the problem. I removed card from bay and removed as much dust i could but it didn`t help. Does it mean that I need to start convincing my Wife that i need new laptop ??? :(

Reply
Options

50 Posts

12-17-2015

US

213 Signins

1551 Page Views

  • Posts: 50
  • Registered: ‎12-17-2015
  • Location: US
  • Views: 1551
  • Message 6 of 8

Re: Lenovo Y510P SLI malfunction

2018-06-11, 1:47 AM
Hmmm I wonder if it is overheating. Download the program called MSI Afterburner and use that to view your temperatures in real-time. It's fairly easy to use, but look at youtube tutorials if you're unsure.

Also grab HWMonitor and run that before you play your games. That'll give you a log of all your temperatures and other statistics. Show us screenshots of both after you pay a game.
y410p - Windows 10 x64 | i7-4700MQ | 16GB RAM |GT 755M SLI| 512GB ZTC M.2 |
3DMark: 4228 - http://www.3dmark.com/fs/7029653
Reply
Options

4 Posts

06-06-2018

PL

12 Signins

68 Page Views

  • Posts: 4
  • Registered: ‎06-06-2018
  • Location: PL
  • Views: 68
  • Message 7 of 8

Re: Lenovo Y510P SLI malfunction

2018-06-17, 9:26 AM

Guys problem solved

 

I used DDU and install older drivers 388.71 and everything went back to normal.

Looks like Nvidia is killing older devices... i wonder why :P

 

Thank You for all answers

 

Reply
Options

50 Posts

12-17-2015

US

213 Signins

1551 Page Views

  • Posts: 50
  • Registered: ‎12-17-2015
  • Location: US
  • Views: 1551
  • Message 8 of 8

Re: Lenovo Y510P SLI malfunction

2018-06-17, 19:08 PM
Not a problem mate, but how curious. I use driver 398.18 with my y410p with SLI and don't have the issues you had.

I wonder what the difference is.
y410p - Windows 10 x64 | i7-4700MQ | 16GB RAM |GT 755M SLI| 512GB ZTC M.2 |
3DMark: 4228 - http://www.3dmark.com/fs/7029653
Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete