cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Phalantax
Paper Tape
Posts: 4
Registered: ‎06-05-2018
Location: PL
Views: 1,725
Message 1 of 8

Lenovo Y510P SLI malfunction

Hi all !

This is my first post, honestly I lost hope to find something in Google and I really need your help.
First of all my Notebook spec:

Lenovo Y510P

Intel Core I5 4200M
8 GB RAM DDR3 (Dual channel)
2x GT 750M (no overclock or sth)
Windows 10 actual version
Graphic Driver actual version (Installed via GeForce experience)

For some time (no idea it happened after Windows or GeForce driver update) after I turn on any game (World of Tanks, Fallout 4, Witcher 3, Frostpunk) there are dramatical graphic errors.

Print screen attached.

Does anyone had similar problem ?

LanceTheeGamer
802.11n
Posts: 50
Registered: ‎12-17-2015
Location: US
Views: 1,674
Message 2 of 8

Re: Lenovo Y510P SLI malfunction

Go to Geforce Experience and check which driver version you're running.
y410p - Windows 10 x64 | i7-4700MQ | 16GB RAM |GT 755M SLI| 512GB ZTC M.2 |
3DMark: 4228 - http://www.3dmark.com/fs/7029653
Phalantax
Paper Tape
Posts: 4
Registered: ‎06-05-2018
Location: PL
Views: 1,667
Message 3 of 8

Re: Lenovo Y510P SLI malfunction

Windows 10 Home (compilation 17134.48)
Drivers WHQL Game Ready driver 398.11.
I tried to install older version of driver, but during system check I got information that drivers are not related to system version. I also cant make a rollback from Windows device manager.
LanceTheeGamer
802.11n
Posts: 50
Registered: ‎12-17-2015
Location: US
Views: 1,649
Message 4 of 8

Re: Lenovo Y510P SLI malfunction

Well the first thing you can try doing is installing the hotfix for driver 398.11: http://nvidia.custhelp.com/app/answers/detail/a_id/4678

Also do you use DDU before installing a new driver?
y410p - Windows 10 x64 | i7-4700MQ | 16GB RAM |GT 755M SLI| 512GB ZTC M.2 |
3DMark: 4228 - http://www.3dmark.com/fs/7029653
Phalantax
Paper Tape
Posts: 4
Registered: ‎06-05-2018
Location: PL
Views: 1,616
Message 5 of 8

Re: Lenovo Y510P SLI malfunction

Well, I installed driver HotFix and reboot PC. After that I turned on Fallout 4 and game was working fine... for 30 seconds. After that I saw same image as before. So overhating looks like the problem. I removed card from bay and removed as much dust i could but it didn`t help. Does it mean that I need to start convincing my Wife that i need new laptop ??? Smiley Sad

LanceTheeGamer
802.11n
Posts: 50
Registered: ‎12-17-2015
Location: US
Views: 1,606
Message 6 of 8

Re: Lenovo Y510P SLI malfunction

Hmmm I wonder if it is overheating. Download the program called MSI Afterburner and use that to view your temperatures in real-time. It's fairly easy to use, but look at youtube tutorials if you're unsure.

Also grab HWMonitor and run that before you play your games. That'll give you a log of all your temperatures and other statistics. Show us screenshots of both after you pay a game.
y410p - Windows 10 x64 | i7-4700MQ | 16GB RAM |GT 755M SLI| 512GB ZTC M.2 |
3DMark: 4228 - http://www.3dmark.com/fs/7029653
Phalantax
Paper Tape
Posts: 4
Registered: ‎06-05-2018
Location: PL
Views: 1,543
Message 7 of 8

Re: Lenovo Y510P SLI malfunction

Guys problem solved

 

I used DDU and install older drivers 388.71 and everything went back to normal.

Looks like Nvidia is killing older devices... i wonder why Smiley Tongue

 

Thank You for all answers

 

LanceTheeGamer
802.11n
Posts: 50
Registered: ‎12-17-2015
Location: US
Views: 1,531
Message 8 of 8

Re: Lenovo Y510P SLI malfunction

Not a problem mate, but how curious. I use driver 398.18 with my y410p with SLI and don't have the issues you had.

I wonder what the difference is.
y410p - Windows 10 x64 | i7-4700MQ | 16GB RAM |GT 755M SLI| 512GB ZTC M.2 |
3DMark: 4228 - http://www.3dmark.com/fs/7029653

Check out current deals!


Shop current deals

Top Kudoed Authors