Showing results for 
Search instead for 
Did you mean: 
Blue Screen Again
Posts: 1
Registered: ‎01-14-2013
Location: California
Views: 8,145
Message 1 of 5

Lenovo Y580 Touchpad not working, help appreciated

Just this morning the touchpad stopped working while i was in the middle of using it. I tried a system restore to yesterday (when it was working just fine) and restarting my laptop and no luck. The laptop is fairly new..I got it late November so I don't know why this is happening. I also tried downloading the synaptics driver touchpad driver and during installation i got an error and now it says no synaptics device found. Very very confused. Any help would be greatly appreciated, going to stop trying to fix it myself now since i have no idea what im doing.

Social Support Agent
Social Support Agent
Posts: 5,824
Registered: ‎02-11-2012
Location: PH
Views: 8,082
Message 2 of 5

Re: Lenovo Y580 Touchpad not working, help appreciated

hi Reversal,


Welcome to the Lenovo Community.


If the touchpad suddenly stopped working, try to:


1. Turn off the computer and remove the AC adapter and battery.

2. Hold the power button for 30secs and re-insert the AC adapter and battery.

3. Turn the computer ON and press F2 to boot into the BIOS, when you're in, press F9 to reset the settings to factory and press F10 to save and exit BIOS.

4. After booting back to the OS, uninstall the current touchpad driver (requires a reboot), then re-install the Touchpad Driver (requires a reboot).


Windows 7 (32bit / 64bit)                                      Windows 8 (32bit / 64bit)

TouchPad Driver (Cypress, Synaptics)              TouchPad (Cypress, Synaptics)
0pto14ww.exe                                                         0pto09w8.exe
142MB                                                                      159MB


5. Make sure Lenovo Energy Management is installed abd press Fn+F6 to disable/enable the Touchpad (For Windows 7, you will see an On screen Display icon if the Touchpad is disabled)

6. If the Touchpad is not moving, check the Device Manager (click Start > type Device Manager) and see if there's any pointing device (i.e. Elan, Synaptics, Lenovo Pointing Device)

7. If you only see an HID mouse (usb mouse),  the Touchpad board might have gotten faulty.


As an additional step, you can re-seat the Touchpad connector (the touchpad is connected on the keyboard bezel - see page 48 of the hardware maintenance manual). If this doesn't work, you will need to contact Lenovo for service as the Touchpad board is already faulty.  Support phone list here.


Hope this helps.

Did someone help you today? Press the star on the left to thank them with a Kudo!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"! This will help the rest of the Community with similar issues identify the verified solution and benefit from it.

Follow us @LenovoSupport on Facebook and Twitter!

Fanfold Paper
Posts: 2
Registered: ‎04-15-2013
Location: Polska
Views: 7,571
Message 3 of 5

Re: Lenovo Y580 Touchpad not working, help appreciated

Hi Everyone, 


I have similar problem with touchpad in my Y580. I have Windows 8 installed and everyday when I'm turning on my laptop touchpad is not working at all or works for about 3-5 second and then suddenly stops. 

If I uninstall drivers and install them again touchpad will work okay. If I leave (turn off, sleep, hibernate) laptop for a short period of time (e.g. 2-3 hours) and then turn on, touchpad works okay. But if I leave laptop for whole night or at least for 6-7 hours the issue still exists (again need to reinstall drivers). 

I've seen a lot of posts on lenovo forum about similar issue I've tried all posted solution but none of them works for me. 


Help appreciated!

What's DOS?
Posts: 2
Registered: ‎06-28-2013
Location: Barcelona
Views: 7,039
Message 4 of 5

Re: Lenovo Y580 Touchpad not working, help appreciated

problem. my touchpad is never working independently if iam using windows 7, 8 or linux.

Paper Tape
Posts: 2
Registered: ‎04-22-2013
Location: Canada
Views: 6,918
Message 5 of 5

Re: Lenovo Y580 Touchpad not working, help appreciated

Smiley Happy 


Your step by step approach worked perfectly for me. Reseat the touch pad connector worked out. Please note that is not necessary to to remove the whole assembly (meaning keyboard) in the case of the y580 as it is mentionned in the post (p.48 of the Lenovo Hardware Maintenance Manual). You can access it through an opening just by removing the 1030 Hard disk drive(HDD)/Memory/Mini PCI Express Card slot compartment cover and the hard drive. It`s the tape ribbon cable you see through an  opening under. Be careful as it is frail. Just push back into the connection  and apply more tape so it holds better. That`s what I did and it worked. 


Device manager saw  to the touchpard afterwards and it worked normally.





Check out current deals!

Shop current deals

Top Kudoed Authors