Showing results for 
Search instead for 
Do you mean 
Reply
Fanfold Paper
Posts: 4
Registered: ‎07-10-2016
Location: NO
Message 1 of 8 (1,181 Views)

Lenovo y50-70 Synaptics touch driver not working properly

[ Edited ]

Hi!
Suddenly my touchpad isnt working as it should. I can now not use two fingers to scroll, not disable the touchpad with F6 and it seems that drivers is not working as it should. I have already tried to download the drivers, but the system tells me that i already got a newer version installed. 

When i rightclick the touchpad to get preassure graph i get this message:
https://gyazo.com/e04c4265c7236014185fa087e7a06acf

This message says that i needs synaptics touchpad and a driver for the synaptics-poitning device.

Further if i go to the mouse device settings for two fingers etc, everything is disabled.
https://gyazo.com/580d168a3dc2d353f8fab165ef100403

This is how the mouse in device manager looks like.
https://gyazo.com/441c8cad3ebef60b843f2f9865469b73

Someone have any ideas? I have tried to download drivers and restart computer, but the problem is still here... hope im not the only one 

 

SOLUTION:
I deleted everything on drivers folder and uninstalled synaptics drivers. Then i did as spidey told me with bios settings. Now i got ELAN smart pad and everything is working fine 

Support Specialist
Posts: 5,190
Registered: ‎11-30-2015
Location: PH
Message 2 of 8 (1,144 Views)

Re: Lenovo y50-70 Synaptics touch driver not working properly

Hi Bennyhoang , 

 

Welcome to the Community Forums.

 

Initially start with downloading the synaptic driver from the support site but don't install it yet and just keep it available maybe saving it on the desktop.

 

Go back to the device manager and completely uninstall the pointing devices ( place a check on a box to completely remove it. 

 

Go to control panel then programs and features and uninstall any software relating to the synaptics. 

 

If you still have D:/ Lenovo / Drivers , try installing the synaptics from the offered driver or use the downloaded driver to reinstall.  

 

Update us how it goes.

 

Regards



Did someone help you today? Press the star on the left to thank them with a Kudo!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"! This will help the rest of the Community with similar issues identify the verified solution and benefit from it.

Follow @LenovoForums on Twitter!

Fanfold Paper
Posts: 4
Registered: ‎07-10-2016
Location: NO
Message 3 of 8 (1,138 Views)

Re: Lenovo y50-70 Synaptics touch driver not working properly

Hi!
I have already tried that... maybe im doing it the wrong way or have the wrong drivers but i have done that like 15 times now.

is this the correct drivers? 
http://support.lenovo.com/no/en/products/laptops-and-netbooks/lenovo-y-series-laptops/y50-70-noteboo...

If there is a way to debug or something please tell me and i can provide with screenshots.

Support Specialist
Posts: 5,190
Registered: ‎11-30-2015
Location: PH
Message 4 of 8 (1,129 Views)

Re: Lenovo y50-70 Synaptics touch driver not working properly

[ Edited ]

Hi Bennyhoang , 

 

You're sure that it was fully uninstalled from the machine? 

Shut down and use the Novo button to power on and choose BIOS set up to load defaults F9 then F10 to save and exit. 

 

If the issue was just recent , you can system restore back to a previous restore point to see if configuration and drivers setting was the issue . We can only say a hardware issue if the same thing would happen even after a factory reset done. 

 

We do have same version for a Win10 Synaptics/ Elan driver.

 

Regards

 



Did someone help you today? Press the star on the left to thank them with a Kudo!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"! This will help the rest of the Community with similar issues identify the verified solution and benefit from it.

Follow @LenovoForums on Twitter!

Fanfold Paper
Posts: 4
Registered: ‎07-10-2016
Location: NO
Message 5 of 8 (1,114 Views)

Re: Lenovo y50-70 Synaptics touch driver not working properly



thats the drivers i am using. Yes i am sure it was fully uninstalled, if not you can try do it yourself through teamviewer if you care to take time Smiley Happy system restore did also not work as it only went to back before i uninstalled drivers... 

Support Specialist
Posts: 5,190
Registered: ‎11-30-2015
Location: PH
Message 6 of 8 (1,076 Views)

Re: Lenovo y50-70 Synaptics touch driver not working properly

Hi Bennyhoang , 

 

Greetings. 

How is the touchpad doing now. 

Ensuring that it is enabled by FN + F6 (page 30) and that device driver would still fail to show up on device manager even after resetting the BIOS on defaults, doing remote would certainly help. You can call in technical support since they would have the needed tools to further check .

 

Regards



Did someone help you today? Press the star on the left to thank them with a Kudo!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"! This will help the rest of the Community with similar issues identify the verified solution and benefit from it.

Follow @LenovoForums on Twitter!

Fanfold Paper
Posts: 4
Registered: ‎07-10-2016
Location: NO
Message 7 of 8 (1,071 Views)

Re: Lenovo y50-70 Synaptics touch driver not working properly

i did as you said earlier and even deleted all folders under drivers. Seems like i had to many different touchpad drivers so maybe thats why it got so mixed up. Anyways, thank you very much for help
Support Specialist
Posts: 5,190
Registered: ‎11-30-2015
Location: PH
Message 8 of 8 (1,062 Views)

Re: Lenovo y50-70 Synaptics touch driver not working properly

Hi Bennyhoang , 

 

Great to know that all is ok.

 

Please don't hesitate to visit our community for your queries and to share your ideas with fellow members at anytime. 

 

Best luck to all your endeavors. 

 

Regards



Did someone help you today? Press the star on the left to thank them with a Kudo!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"! This will help the rest of the Community with similar issues identify the verified solution and benefit from it.

Follow @LenovoForums on Twitter!

Top kudoed Authors