English Community

Lenovo NotebooksLenovo P, Y and Z series Notebooks
All Forum Topics
Options

0 Posts

02-04-2020

US

0 Signins

0 Page Views

  • Posts: 0
  • Registered: ‎02-04-2020
  • Location: US
  • Views: 0
  • Message 1 of 3

Levovo Y50-70 GPU not working correctly

2020-02-04, 19:16 PM

I have a Levovo Y50-70 with an Intel Core i7 4720HQ, 16 gb of ddr3 RAM, (Nvidia GTX 960M) here is speccy application motherboard info Manufacturer LENOVO
Model Lenovo Y50-70 (U3E1)
Version K0J40709WIN
Chipset Vendor Intel
Chipset Model Haswell
Chipset Revision 06
Southbridge Vendor Intel
Southbridge Model HM87
Southbridge Revision C2

 

Windows 10 home edition

 

I am having problems running games. Differing error's/codes but same result. I can start and run but games end up crashing anywhere from 5 to 15 min in. Pretty much always when I have started gameplay. Always a graphics error of some kind. Modern warfare says error code 6068, Ghosts says hung device error, and warface just says application stopped working. Games include Call of duty modern warfare (2019), and COD Ghost's, Warface and other smilar fps games. I ran diagnosics on this website on simple scan mode and 14/14 passed. I feel like it matches driver issiues from what I can see on google. On device manager under display adapters (Nvidia GTX 960M) says device is functioning correctly. I have tried a few different drivers for GPU, from both NVIDIA website and Leveno. I feel it is likely a combonation of driver but something else as well. Not an expert but I did buy this laptop preowned it was already updated to windows 10 from windows 8, so I assume it could be some kind of compatabilty issue with OS/ software- hardware. I need help figuring out or narrowing down what kind of issue's im having and finding a fix. It seems everything is physicaaly functioning but device is way too laggy on startup, and into gaming. Something seems off with software or firmware, just not sure what...

Reply
Options

0 Posts

02-04-2020

US

0 Signins

0 Page Views

  • Posts: 0
  • Registered: ‎02-04-2020
  • Location: US
  • Views: 0
  • Message 2 of 3

Re: Levovo Y50-70 GPU not working correctly

2020-02-04, 19:17 PM

BTW serial number is ********

 

Moderator note: serial number removed to prevent abuse.  Corresponding MT-M is 80EJ59445892

Reply
Options

293 Posts

11-26-2019

HK

124 Signins

2553 Page Views

  • Posts: 293
  • Registered: ‎11-26-2019
  • Location: HK
  • Views: 2553
  • Message 3 of 3

Re: Levovo Y50-70 GPU not working correctly

2020-02-05, 0:56 AM
Please Remove the serial number. Moderators will do it anyway
Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save