Support in other languages: 
Showing results for 
Search instead for 
Do you mean 
Posts: 7
Registered: ‎03-19-2008

Linux (Ubuntu) Sound Problems Semi-Resolved for Lenovo 3000 Y410 - step by step (Realtek ALC262)

[ Edited ]


Disclaimer:  This tutorial was written for absolute n00bs!  I mean the "I've never seen a command prompt/terminal before" or "What's Ubuntu?" kinda n00b.  For those experienced Linux users, my sincerest apologies. :smileywink:


The initial fix for my Lenovo sound problem worked until the next reboot.  When my pc booted into Ubuntu just after the fix the sound no longer worked.  I've found that putting the computer on standby and waking it up revives the sound, but plugging the headphones in won't cutoff the front speakers (once again).  At the end of this post I'll explain a simple way to mute the front speakers while keeping the headphones on.



  1. Open your terminal.  This can be accomplished a number of ways, but if you have the latest Ubuntu installed you can find the terminal by going to: Applications>Accessories>Terminal  (The Applications dropdown is in the upper-right hand of your screen).
  2.  Copy this code: 

    sudo nano /etc/modprobe.d/alsa-base

  3. Now paste the code in your terminal by right-clicking in the terminal and selecting "Paste" from the dropdown menu.
  4. Don't try the Ctrl-c and Ctrl-v shortcuts here, it will not work.
  5. Once the code is pasted press your Return or Enter key.
  6. You will be prompted for your password. Make sure to type it slow and steady since you won't be able to see what you're typing while you type.
  7. Press Enter
  8. This should open a small editing program within the Terminal
  9. Now scroll down within the Terminal until you see this line of code:
  10. # Ubuntu #62691, enable MPU for snd-cmipci
    options snd-cmipci mpu_port=0x330 fm_port=0x388

  11. You'll have to use the arrow keys on your keyboard to navigate the cursor.
  12. Navigate just to the # symbol in the code
  13. Press Enter
  14. Navigate to the new blank space
  15. Input this code:
  16. options snd-hda-intel model=lenovo

  17. The finished code towards the bottom should look something like this:
  18. options snd-usb-caiaq index=-2
    options snd-hda-intel model=lenovo
    # Ubuntu #62691, enable MPU for snd-cmipci
    options snd-cmipci mpu_port=0x330 fm_port=0x388

  19. Go ahead and exit out of the terminal.
  20. You should be prompted to save the code, go ahead and save your changes.
  21. Presto frickin chango, you should be able to hear out of both your headphones and speakers!




It seems my initial sound fix was only temporary.  When Ubuntu rebooted the sound appeared to be broken again.



I was fortunate enough to discover that putting my Lenovo in standby (by pressing Fn-F1) actually revived the sound.  Unfortunately, the sound continued to play out of the speakers even though my headphones were plugged in.


I had to Jerry rig a solution on this one.  It's not pretty, but it does the trick when you need it to:


Go to your "Applications" dropdown list and click on the Install/Uninstall option at the very bottom.  Select the "Sound" option on the left to modify your search.  Search for the term "Alsa mixer".  Once you've found the program install it.  


Using the Alsa mixer will enable you to control each sound element on your computer = you can mute the "front" while keeping your headphones on.




Message Edited by theproles on 10-23-2008 05:54 AM
Message Edited by theproles on 10-23-2008 05:55 AM
Punch Card
Posts: 28
Registered: ‎08-28-2008

Re: Linux (Ubuntu) Sound Problems Resolved for Lenovo 3000 Y410 - step by step (Realtek ALC262)

The files from the Realtek website seem to be nothing more than alsa driver version 1.0.16.  Most modern distros include version 1.0.17 already; and version 1.0.18 is almost ready for release.  Therefore, you could probably skip the download and install altogether, and just modify the version 1.0.17 module parameters (model=lenovo) and be done.


Did the driver included in Ubuntu 8.04, using the model=lenovo option, fail on your hardware?

Posts: 7
Registered: ‎03-19-2008

Re: Linux (Ubuntu) Sound Problems Resolved for Lenovo 3000 Y410 - step by step (Realtek ALC262)

The alsa drivers did actually fail on the next reboot.  I'm completely new to Ubuntu myself, I was just fortunate enough to find something that semi-worked for me.  You're definitely right about simplifying the sound solution.  I'll be updating my original post to reflect the changes.
What's DOS?
Posts: 1
Registered: ‎11-17-2008

Re: Linux (Ubuntu) Sound Problems Resolved for Lenovo 3000 Y410 - step by step (Realtek ALC262)

For all lenovo y410 problems regarding sound or wireless, try to upgrade to la latest version of ubuntu (ubuntu 8.10). It has all the fixes for the sound (speaker & headphone) problems including wireless LAN. I still have to check on other stuffs though; Bluetooth, webcam, etc.
Token Ring
Posts: 64
Registered: ‎08-08-2008

Re: Linux (Ubuntu) Sound Problems Resolved for Lenovo 3000 Y410 - step by step (Realtek ALC262)

Well as of now, the new Ubuntu version 9.04, will solve all your problems. I'm now using Ubuntu 9.04 as my primary OS in my Y410. It simply rocks.. Most of the things work fine.

Y410-160GB HDD,T5550,2GB RAM
Ubuntu 9.04 -Gnome, Win Vista(not used much) Smiley Happy Ubuntu rocks...Smiley Wink
Final Year BTech(CSE) Student