cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
anj510
Paper Tape
Posts: 1
Registered: ‎02-09-2013
Location: Oakland, CA
Views: 775
Message 1 of 2

New Ideapad Y480 won't run on battery!

Hi everyone, I'm a new user to this forum and also a new owner of an Ideapad Y480.  I've discovered that it won't power up if it's not plugged in!  After doing some quick research on-line I tried removing and then re-installing the battery, which didn't make a difference; in fact, before the little battery indicator light on the front of the machine was on; after removing & re-inserting the battery, it is no longer on, so it seems like I'm going in the wrong direction. Smiley Wink

  The only other diagnostic thing I've tried is to unplug the power cord while the machine is on, to see if it would continue running on battery power--it does not.  The screen immediately goes dark and I have to press the power button again to start up.

Did I forget to do something that everyone else knows to do when starting to use a new laptop?  (I'm far from a tech guru and this is my first laptop since I had one of the first Apple Powerbooks (I think a 140?) in the mid-90s!)

   I read an answer on a somewhat similar question that suggested removing the battery and holding the power button down for 30 seconds...would this be appropriate?  Another idea I saw was removing the battery and trying it on a different machine (to see if it's the battery or something else, I assume)...which I suppose I can try at my local Best Buy?

  Thanks for any help you can provide!

Highlighted
Social Support Agent
Social Support Agent
Posts: 5,822
Registered: ‎02-11-2012
Location: PH
Views: 746
Message 2 of 2

Re: New Ideapad Y480 won't run on battery!

hi anj510,

 

Welcome to the Lenovo Community.

 

Windows uses the Microsoft ACPI Compliant Control Method Battery to charge laptop' batteries. Can tiy try to:

 

1. Boot into the BIOS by pressing F2. When you're in, press F9 to load BIOS to defaults and press F10 to save and exit BIOS.

2. Refresh this settings under Device Manager (click Start > type Device Manager > navigate to Batteries > right click and uninstall Microsoft ACPI Compliant Control Method Battery and reboot).

3. Perform a battery gauge reset.

4. If still no go, try to uninstall Lenovo Energy Management and let windows take control of the power scheme.

5. Try to use Passmark's BatteryMon to check the health of the battery.

 

If you still get the same problem,  there's probably a problem with the battery socket or the battery itself. Try to use a different battery or contact lenovo to exchange the possible defective battery. Support phone list here.

 

 

Hoep this helps.



Did someone help you today? Press the star on the left to thank them with a Kudo!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"! This will help the rest of the Community with similar issues identify the verified solution and benefit from it.

Follow us @LenovoSupport on Facebook and Twitter!

Check out current deals!


Shop current deals

Top Kudoed Authors