English Community

Lenovo NotebooksLenovo P, Y and Z series Notebooks
All Forum Topics
Options

26 Posts

04-09-2013

Washington

35 Signins

208 Page Views

  • Posts: 26
  • Registered: ‎04-09-2013
  • Location: Washington
  • Views: 208
  • Message 1 of 9

New Z400's Bluetooth stopped working with error code 43

2013-04-09, 7:33 AM

My Z400 arrived on last Friday and its BT stopped working two days later. When I checked its status in the Device Manager, I found this error message in its Property box: "Windows has stopped this device because it has reported problems. (Code 43"

 

Googling this code, I've found several people reporting it, and even for Windows 7, or the Intel BT, so it looks like a Microsoft driver issue and not a hardware problem. I wonder if this happened to anybody else here and found a fix for it. 

Solved! See the solution
Reply
Options

3333 Posts

06-27-2012

India

5394 Signins

57727 Page Views

  • Posts: 3333
  • Registered: ‎06-27-2012
  • Location: India
  • Views: 57727
  • Message 2 of 9

Re: New Z400's Bluetooth stopped working with error code 43

2013-04-09, 17:14 PM
Hi
Can you give reinstalling the drivers a try?
You can either find it here
http://support.lenovo.com/en_IN/downloads/detail.page?DocID=DS033356
Or in the d drive drivers folder.
Ishaan Ideapad Y560(i3 330m), Hp Elitebook 8460p!(i5-2520M) Hp Pavilion n208tx(i5-4200u)
If you think a post helped you, then you can give Kudos to the post by pressing the Star on the left of the post. If you think a post solved your problem, then mark it as a solution so that others having the same problem can refer to it.

0 person found this solution to be helpful.

This helped me too

Reply
Options

26 Posts

04-09-2013

Washington

35 Signins

208 Page Views

  • Posts: 26
  • Registered: ‎04-09-2013
  • Location: Washington
  • Views: 208
  • Message 3 of 9

Re: New Z400's Bluetooth stopped working with error code 43

2013-04-09, 18:06 PM

Ishaan,

thanks for that tip. I downloaded the Intel driver from the link you included in your post and it fixed my BT problem. Way to go!

Reply
Options

3333 Posts

06-27-2012

India

5394 Signins

57727 Page Views

  • Posts: 3333
  • Registered: ‎06-27-2012
  • Location: India
  • Views: 57727
  • Message 4 of 9

Re: New Z400's Bluetooth stopped working with error code 43

2013-04-10, 15:56 PM
Welcome NWdude :D
Ishaan Ideapad Y560(i3 330m), Hp Elitebook 8460p!(i5-2520M) Hp Pavilion n208tx(i5-4200u)
If you think a post helped you, then you can give Kudos to the post by pressing the Star on the left of the post. If you think a post solved your problem, then mark it as a solution so that others having the same problem can refer to it.
Reply
Options

26 Posts

04-09-2013

Washington

35 Signins

208 Page Views

  • Posts: 26
  • Registered: ‎04-09-2013
  • Location: Washington
  • Views: 208
  • Message 5 of 9

Re: New Z400's Bluetooth stopped working with error code 43

2013-04-11, 17:14 PM

Unfortunately, my happiness about the Bloetooth fix was short lived. When I booted up the notebook today, the BT was dead again with the same Code 43 status in the Device Manager Properties sheet. So I wonder what causes the BT to live for such a short time. Any ideaswhat I might try next time, Ishaan?

Reply
Options

3333 Posts

06-27-2012

India

5394 Signins

57727 Page Views

  • Posts: 3333
  • Registered: ‎06-27-2012
  • Location: India
  • Views: 57727
  • Message 6 of 9

Re: New Z400's Bluetooth stopped working with error code 43

2013-04-12, 11:39 AM
Hi
Could you try uninstalling the device from the device manager and then reeboot and then try reinstalling drivers once again. You can also try installing the drivers from the d drive.
If this also doesn't help, can you provide me the hardware id of your bluetooth? Go to device manager, right click the device, click properties, go to the last tab and choose hardware ids from the dropdown menu.
Ishaan Ideapad Y560(i3 330m), Hp Elitebook 8460p!(i5-2520M) Hp Pavilion n208tx(i5-4200u)
If you think a post helped you, then you can give Kudos to the post by pressing the Star on the left of the post. If you think a post solved your problem, then mark it as a solution so that others having the same problem can refer to it.
Reply
Options

26 Posts

04-09-2013

Washington

35 Signins

208 Page Views

  • Posts: 26
  • Registered: ‎04-09-2013
  • Location: Washington
  • Views: 208
  • Message 7 of 9

Re: New Z400's Bluetooth stopped working with error code 43

2013-04-12, 17:17 PM

wrote:
Hi
Could you try uninstalling the device from the device manager and then reeboot and then try reinstalling drivers once again. You can also try installing the drivers from the d drive.
If this also doesn't help, can you provide me the hardware id of your bluetooth? Go to device manager, right click the device, click properties, go to the last tab and choose hardware ids from the dropdown menu.

You know what? That BT just started working again at the next bootup without any change on my part. I wonder how that happened. Maybe some update was pushed through in background I did not know about. So it's working fine again. I just hope this not going to be repeating itself periodically like some yo-yo.

Reply
Options

3333 Posts

06-27-2012

India

5394 Signins

57727 Page Views

  • Posts: 3333
  • Registered: ‎06-27-2012
  • Location: India
  • Views: 57727
  • Message 8 of 9

Re: New Z400's Bluetooth stopped working with error code 43

2013-04-12, 18:38 PM
I also hope that doesn't occur anymore or at the least, not persistently. If you do face this again, try what i told about in my last post.
Ishaan Ideapad Y560(i3 330m), Hp Elitebook 8460p!(i5-2520M) Hp Pavilion n208tx(i5-4200u)
If you think a post helped you, then you can give Kudos to the post by pressing the Star on the left of the post. If you think a post solved your problem, then mark it as a solution so that others having the same problem can refer to it.
Reply
Options

26 Posts

04-09-2013

Washington

35 Signins

208 Page Views

  • Posts: 26
  • Registered: ‎04-09-2013
  • Location: Washington
  • Views: 208
  • Message 9 of 9

Re: New Z400's Bluetooth stopped working with error code 43

2013-04-12, 22:16 PM
Thanks again. I'' do what you suggested.
Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save