English Community

Lenovo NotebooksLenovo P, Y and Z series Notebooks
All Forum Topics
Options

2 Posts

10-21-2014

uk

8 Signins

28 Page Views

  • Posts: 2
  • Registered: ‎10-21-2014
  • Location: uk
  • Views: 28
  • Message 1 of 3

New z50 70 with connection problems

2014-11-03, 16:04 PM

Have new z50 70 with continuing wifi connection problems. 

- ethernet connection ok so just wifi problem

-other pc's ok using this router (Thomson Gateway TG585v7) 

- updated driver and changed channel - no improvement

- returned pc and tried replacement - same problem with regular  dropped connection

- tried pc on neighbours router and monitored connection - no problems

Still dont know whether it is a pc or router problem and am reluctant to buy a new router just to find out. Any suggestions gratefully received

 

 

Solved! See the solution
Reply
Options

65 Posts

09-15-2014

US

140 Signins

1087 Page Views

  • Posts: 65
  • Registered: ‎09-15-2014
  • Location: US
  • Views: 1087
  • Message 2 of 3

Re: New z50 70 with connection problems

2014-11-05, 0:33 AM

This is definitely your wifi router.  See if there are any firmware updates for it.

 

We bought three of these Y50's and two of our users had problems with wifi drop-outs and timeouts frequently.  Both turned out to have older, junk, no name or super old linksys g wifi.  Replacing them with modern NetGear Wireless-N routers not only doubled their connection speed but also creates perfect connection, signal strength even across the house and never a drop/super stable connection.

 

I have an older NetGear that is g and N capable and my Y50 was perfect out of the gates, even if I connect and test with the g-SID.

 

Good luck!

0 person found this solution to be helpful.

This helped me too

Reply
Options

2 Posts

10-21-2014

uk

8 Signins

28 Page Views

  • Posts: 2
  • Registered: ‎10-21-2014
  • Location: uk
  • Views: 28
  • Message 3 of 3

Re: New z50 70 with connection problems

2014-11-13, 15:08 PM

Thanks for your reply Steve - it appears that the router was the problem even though it was ok with other pc's tablet and phone. Still dont really understand why. However have bought a new router (TP LINK) which is a big improvement. Have monitored the connection and it still drops occassionally but only momentarily whch restarts the time lapse counter on the Networx program but does not register on the online offline history for some reason. Nevertheless i have not noticed any problems in use so as far as i am concerned it is fixed. Thanks for your suggestion.

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete