cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
rossoneri
What's DOS?
Posts: 2
Registered: ‎09-14-2008
Location: Singapore
Views: 1,177
Message 1 of 4

No power, No LED lights at all. (Y400)

No charging LED light at all when plugged into AC Adaptor, thereafter tried the following:

1) Removed battery and plugged into AC Adaptor, nothing lights up as well

2) Only battery in, tried powering on, nothing happens.

3) Tried brand new battery bought from service centre the previous day (Oh, the irony of it all!), same as 2), nothing happens.

 

Charger is definitely working as tested using multimeter.

 

Looks like it's something wrong with the voltage regulator/some other power component? Laptop is 18 months old.

 

Wondering if this is the case, how fast can I get it fixed? I am flying off in a few days for quite a few months and I was supposed to bring the laptop with me, so hoping I can get it fixed in time! (looking at about 2-3 working days left?)

Highlighted
Retired Guru
Posts: 2,308
Registered: ‎03-12-2008
Location: Moscow, Russia
Views: 1,150
Message 2 of 4

Re: No power, No LED lights at all. (Y400)

Sounds like some device inside is dead. By sympthoms it' mobo or cpu - all others won't caue such a behaviour.

Bad luck. Way to service centre or new laptop buying procedure...

//help will save the world
pm93529
Fanfold Paper
Posts: 4
Registered: ‎01-28-2008
Location: Baja California MX
Views: 776
Message 3 of 4

Re: No power, No LED lights at all. (Y400)

What ended up being your problem...my Lenovo N200 just did the same thing...and I have done exactly what you did to try to correct?

rossoneri
What's DOS?
Posts: 2
Registered: ‎09-14-2008
Location: Singapore
Views: 769
Message 4 of 4

Re: No power, No LED lights at all. (Y400)

Power unit failure. Had to go down to the service centre. Hopefully yours is still under warranty as I was told it required a motherboard change!

Check out current deals!


Shop current deals

Top Kudoed Authors