English Community

Lenovo NotebooksLenovo P, Y and Z series Notebooks
All Forum Topics
Options

8 Posts

08-17-2016

IT

6 Signins

56 Page Views

  • Posts: 8
  • Registered: ‎08-17-2016
  • Location: IT
  • Views: 56
  • Message 1 of 5

Z50-70 - Novo button doesn't work

2017-03-20, 12:13 PM

Hi guys, I've this problem: the novo button doesn't work at all. I pressed it when the computer is off and then my Lenovo z50-70 boots normally,ideas??

 

Mod's Edit: System model added to the front of Subject line to improve visibility / clarity.

 

Solved! See the solution
Reply
Options

12058 Posts

11-30-2015

PH

7112 Signins

743024 Page Views

  • Posts: 12058
  • Registered: ‎11-30-2015
  • Location: PH
  • Views: 743024
  • Message 2 of 5

Re: Z50-70 - Novo button doesn't work

2017-03-20, 13:44 PM

Hi kizzone , 

 

Welcome to the Community Forums. 

 

While unplugged, try removing the battery and press and hold down the power button for 12 seconds.

Connect the ac charger and press the Novo button (item2 page 69).

 

Are you planning on doing a full factory reset (to lauch within windows) or just going in the BIOS (alternate option FN+ F2)?

 

As long as the hidden partition is intact and no changes made to the partitioning like resizing , try checking via disk management

 

Update us how it goes.

 

Regards



Did someone help you today? Press the thumbs-up icon below to thank them.!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"! This will help the rest of the Community with similar issues identify the verified solution and benefit from it.


Using Browser Search to find your answers in Lenovo and Moto Community

Reply
Options

12058 Posts

11-30-2015

PH

7112 Signins

743024 Page Views

  • Posts: 12058
  • Registered: ‎11-30-2015
  • Location: PH
  • Views: 743024
  • Message 3 of 5

Re: Z50-70 - Novo button doesn't work

2017-03-20, 13:44 PM

Hi kizzone , 

 

Welcome to the Community Forums. 

 

While unplugged, try removing the battery and press and hold down the power button for 12 seconds.

Connect the ac charger and press the Novo button (item2 page 69).

 

Are you planning on doing a full factory reset (to launch within windows) or just going in the BIOS (alternate option FN+ F2)?

 

As long as the hidden partition is intact and no changes made to the partitioning like resizing , try checking via disk management

 

Update us how it goes.

 

Regards



Did someone help you today? Press the thumbs-up icon below to thank them.!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"!
This will help the rest of the Community with similar issues identify the verified solution and benefit from it.


Using Browser Search to find your answers in Lenovo and Moto Community

0 person found this solution to be helpful.

This helped me too

Reply
Options

8 Posts

08-17-2016

IT

6 Signins

56 Page Views

  • Posts: 8
  • Registered: ‎08-17-2016
  • Location: IT
  • Views: 56
  • Message 4 of 5

Re: Z50-70 - Novo button doesn't work

2017-03-20, 14:00 PM

Hi, no I don't want to do a factory reset since I'm not using Windows .I've tried to removing the battery and press and hold down the power button for 12 seconds but didn't work, and  the laptop takes a lot to start with no boot screen. Fn+F2 works just fine for entering the bios.Thanks a lot!

Reply
Options

1 Posts

04-24-2017

IN

1 Signins

16 Page Views

  • Posts: 1
  • Registered: ‎04-24-2017
  • Location: IN
  • Views: 16
  • Message 5 of 5

Re: Z50-70 - Novo button doesn't work

2017-04-24, 2:44 AM

Hi, I ws too facing this problem what i did was just go into the device manager and then in display adapters the intel one actually first try to update it if still the problem presists than disable the intel graphics manager then enable it in my case it helped Hope in your will also

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete