cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
haleba
Blue Screen Again
Posts: 4
Registered: ‎05-09-2013
Location: US
Views: 197
Message 1 of 1

SOLVED at Last: Synaptics Touchpad Freezes (Lenovo Z585, Win 8.1 64-bit)

There's always been an issue with the Synaptics touchpad mouse on my IdeaPad Z585 and I have seen quite a few postings of issues with the touchpad on this and other forums.

 

The freezes appear to be mainly related to disk activity: Synaptics Touchpad Enhancements (C:\Program Files\Synaptics\SynTPSynTPEnh.exe on my system) is often very near the top of disk activity in Task Manager and when the system disk activity "pegs" at 100% for extended periods of time the touchpad--especially the swiping features--becomes unresponsive.

 

Lately the the problems have become more severe, with the freezes--often lasting 5 minutes or longer--occuring even at very modest resource usages, and the only way to avoid a complete restart is to switch to the Guest account using the keyboard.

 

The past few weeks the problems have become quite severe, with multiple 5+ minute freezes and perhaps three quarters of an hour lost working time switching between Guest and my personal login or rebooting.

 

Desperately I searched one more time for a solution and came across

 

Split x2 - Touchpad issue after upgrading to Windows 8.1 - HP Community/Archived Topics/Notebooks Ar...

 

with the accepted solution

 

"this worked for me.

 

Go to Generic USB Hub (both of them) in Device Manager.

 

Go to the Power Management tab

 

Uncheck the box about allowing the computer to turn off this device to save power.

 

Restart.

 

My touch pad had stopped while searching for a solution on this forum. I 'unchecked ' the boxes and the touchpad came bacxk to life before the restart. It has been working ever since. (three days)"

 

On my system there are four USB Root Hubs and one Extensible Host Controller Interface (xHCI) USB Root Hub under Device Manager/View/device by type/Universal Serial Bus Controllers. I unchecked as instructed and for the past week there hasn't been one prolonged touchpad freeze, even with the system resources maxed out!

 

Checking for this post I inadvertently clicked the box back on one root hub and the problem restarted immediately. After unchecking and restarting I loaded the system by starting two browsers as I had before the restart to make sure this was the solution and there were no issues, so I can now definitely vouch for this.

 

The only mystery now (aside from why the touchpad is so sensitive to begin with) is what in the world USB power management has to do with the mouse subsystem. Makes absolutely no sense but I'm not complaining Smiley Happy

 

 

Check out current deals!


Shop current deals

Top Kudoed Authors