cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
edwardwetrust
Paper Tape
Posts: 1
Registered: ‎12-13-2018
Location: US
Views: 259
Message 1 of 1

[Solved] Lenovo y410 Ideapad: Working Driver for Intel Centrino N2230

I recently updated my Lenovo Y410p to a SSD with a clean install of windows. Because of this, all my drivers are out of date. Some background on my laptop:

 

When I first purchased it in 2014, the Intel Centrino N2230 wireless adapter was not working whatsoever. It was constantly dropping connection every minute. There were plenty of complaints about it online with many proposed solutions, all of which did not work for me. I spent weeks trying to troubleshoot the wireless card to no avail. My laptop essentially did not have wireless capabilities during this duration, until a driver update came through that fixed everything. I never had a Wi-Fi problem again in the last 3 years. 

 

I upgraded to a SSD yesterday, and the wireless adapter is once again not working. I know 100% it is the Intel Centrino N2230 drivers once again because those weeks of trying to troubleshoot it are so painfully unforgettable. It has the exact same symptoms again. I thought it would just be a simple fix of updating the driver. However, when I go to the Lenovo Y410P Product page to look for the drivers, the Intel Centrino N2230 wireless adapter is no longer there: 

 

https://pcsupport.lenovo.com/us/en/products/laptops-and-netbooks/ideapad-y-series-laptops/ideapad-y4...

 

The closest thing was the WLAN driver, but when I try installing that, it just makes me install Intel Proset/Wireless, which does nothing for updating my driver. Maybe I'm using it wrong, but when I install Intel Proset/Wireless, Intel's page says the network adapter should automatically be updated. However, when I check my device manager, it seems like the driver version stays the same. I suspect this is because intel does not support discontinued products anymore:

 

I went onto Intel's website to try and find the driver there, but the Intel Centrino N2230 has been discontinued. They took down every single driver update for their discontinued products, and instead, redirects you back to your laptop manufacturer. However, Lenovo does not have the network adapter driver update (above). 

 

Right clicking the card in Windows Device Manager and trying to update the driver automatically through there also doesn't seem to work. It says it updated to the most recent version, but this version was published in 2013. Basically every driver version before ~2015 (when the driver udpate that fixed my card came out) does not work.

 

What can I do? My laptop is once again basically useless because Wi-Fi is not working on it. I am on Windows 8.1.

 

 

EDIT 1: Installing Intel Proset/Wireless does update my Intel Centrino N2230 driver version. Is just a matter of finding the correct version now from Softpedia. Will update when I found the working version for anyone who stumbles on this in the future. Currently using version 15.18.0.1 (on Softpedia, it was called 19.70.0 though). If anyone has a Lenovo Y410p, please let me know which version you have and if it works

 

EDIT 2: Version 15.18.0.1 appears to be a working version. Marking solved

Check out current deals!


Shop current deals

Top Kudoed Authors