cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
ki4kk
Paper Tape
Posts: 1
Registered: ‎02-14-2013
Location: Oak Island, North Carolina
Views: 8,403
Message 1 of 2

Synaptics Touchpad Driver not starting in Windows 7

Within the last year the Synaptics touchpad on my Ideapad Y530, running Windows 7 Pro, became intermittent.  Because I use a mouse, this was not much of an issue but I did try to fix the problem.  I read all the forums, uninstalled and reinstalled the driver, even trying some other drivers from the Synaptics website (this may not have been a good idea).  Nothing worked and I let it rest.  Most recently I took the laptop to a meeting and forgot the mouse.  Negotiating through Windows is not all that easy without a mouse or buttons, but I did manage to get what I wanted and get out gracefully.  So, I decided to revisit the touchpad issue.

 

The first thing I noticed is that the touchpad is not listed in the Device Manager.  There is an Unknown Device but trying to install a driver using the automatic search did nothing.  I uninstalled and reinstalled using the driver from the Lenovo site.  It does not work.  I then saw that in the C:\Drivers\ folder, Windows explorer shows TWO Synaptics Pointing Device Driver folders.  I uninstalled the driver and one folder went away but the other is still there.  I tried to delete this folder but Windows Explorer says it Could not find this item.  If I try using the CMD prompt, a dir shows the directory but if I try to CD Synaptics Pointing Device Driver it says PATH NOT FOUND.  In Windows Explorer I can double click on the folder and it shows three entries (the ones installed by the Synaptics installation).  I deleted these three entries successfully and the directory is now empty.  But I can still not delete it and I can not rename it.  If I reinstall the driver, a second directory is setup.  I was able to COPY all of the files in the second directory to the Ghost directory but the touch pad driver still did not install.

 

When I start the system, the Synaptics driver is not getting started.  In MSCONFIG it shows the path as

%Program Files%\Synaptics\SynTP\SynTPEnh.exe

All of the other entries in MSCONFIG show C:\xxxx as the path

 

If I try to run SynZMetr.exe (some type of pressure graph program in the Synaptics directory), it says Sorry, this program requires a Synaptics Touchpad and the Synaptics Device Driver. 

 

I would like to delete the Ghost directory to make sure this is not the problem.  It has been so long since I used the DOS commands I am foggy on what the %Programs% does compared to the C:\Programs definition in the MSCONFIG. 

 

Any ideas would be appreciated.

 

ADDITIONAL FINDINGS:  I fixed the Unknown Device problem (power management unrelated to touchpad).  The Driver is installed and looks OK in the registry.  The touchpad is not showing up in the Device Manager.  My only question now is "If the touchpad fails completly will it just disappear from the Device Manager?"  If so, then I don't need to go further to look for a solution.

 

FINAL CONCLUSION:  I fixed the Ghost directory using CMD dir /x and removing the directory with that name.  Uninstalling and reinstalling does nothing.   Everything looks in the right place in the registry and directories.  The Touchpad is not being recognized so my final conslusion is that is has failed and it is a hardware problem.

 

 

Retired Support Specialist
Posts: 1,241
Registered: ‎11-02-2011
Location: India
Views: 8,371
Message 2 of 2

Re: Synaptics Touchpad Driver not starting in Windows 7

 

 

 

 

 

 

Hi

 

Welcome To Lenovo Community

 

We are really sorry to hear about the issue you are facing,  

 

Please try a complete Power Drain instead of shutting down and restarting (remove battery/ac power and leave off for a minute), then press the power button for 30-40 sec, Now connect battery and adaptor power on the system

 

 After Powering on press F2 to boot into the BIOS, when you're in Bios, press F9 to reset the settings to factory and press F10 to save and exit BIOS.

 

After booting back to the OS, uninstall the current touchpad driver, press Fn+F6 to disable/enable the Touchpad, you will see an On screen Display icon if the Touchpad is disabled or enabled

 

Restart the system. Try installing the following drivers

 

Ideapad Y530 series touchpad driver Win7 32 Bit

 

Ideapad Y530 series touchpad driver Win7 64 Bit

 

If this doesn't work, you will need to contact Lenovo for service. Support phone list here.

 

Do give this a try and let us know  

 

 

 

Hope This Helps

Cheers!!!

 

 

 

------------------------------------------------------------------------------------------------------------------------------------------------------------------

WW Social Media
Important Note: If you need help, post your question in the forum, and include your system type, model number and OS. Do not post your serial number.

Did someone help you today? Press the star on the left to thank them with a Kudo!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"!

Follow @LenovoForums on Twitter!
How to send a private message? --> Check out this article.


                        English Community   Deutsche Community   Comunidad en Español

 

Check out current deals!


Shop current deals

Top Kudoed Authors