cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Swedboy
Blue Screen Again
Posts: 1
Registered: ‎09-29-2013
Location: UK
Views: 1,203
Message 1 of 4

Touchpad stopped working z580

Hi,

 

Last night my touchpad just died on me (It's less than 3 months old). First I just thought it has frozen and would snap back as it did an hour before but it didn't. Have tried to download the Synaptics Touchpad Driver for Microsoft Windows 8 (32-bit, 64-bit) - IdeaPad Z380, Z480, Z580 but that doesn't help at all. Not sure it actually installed it correctly. The installation doesn't seem to go to compilation and the progress box disappears halfway through the install.

 

 Read on an other thread here that you needed to uninstall the Synaptics software but that didn't help. The software did reappear after startup (http://forums.lenovo.com/t5/IdeaPad-Y-U-V-Z-and-P-series/Touch-pad-not-working-Z580/td-p/1201254). According to that thread you need to remove it from the devise manager too, but I can't find anything relating to that in the devise manager.

 

Tried this thread's solution too but to no avail. https://forums.lenovo.com/t5/IdeaPad-Y-U-V-Z-and-P-series/z580-touchpad-not-working-properly-with-wi.... That just failed full stop.

 

I could at one point today see a levono pointing device in the drive manager but that has now disappeared. It said the following: :Currently, this hardware device is not connected to the computer. (Code 45) To fix this problem, reconnect this hardware device to the computer.

 

That entry has now vanished.

 

I have also reverted the system to a restorepoint when it worked but that didn't help.

 

What to do? Not keen on having to travel for over an hour to return it to John Lewis

 

Retired Moderator
Retired Moderator
Posts: 13,719
Registered: ‎12-07-2009
Location: CZ
Views: 1,196
Message 2 of 4

Re: Touchpad stopped working z580

hi there,

it's possible loose cable/connector or hardware issue. i suggest you to re-install the system by pressing one key recover button ( i don't think it's going to work but you can try ) or just contact lenovo for hardware support.


http://www.krasotaiskusstva.com
tommin123
Paper Tape
Posts: 1
Registered: ‎12-21-2014
Views: 837
Message 3 of 4

touchpad doesnt work

Hi,

 

I need some help. It seems that my touchpad doesnt work anymore. I tried installing new driver, but it still doesnt work. Mouse is working fine, Could someone help me what to do? My laptop is Ideapad Z380. Thank you so much

Retired Moderator
Retired Moderator
Posts: 13,719
Registered: ‎12-07-2009
Location: CZ
Views: 815
Message 4 of 4

Re: touchpad doesnt work

To make sure if it's not windows/software issue, as I suggested before/above, could you please try to perform clean windows installation if it's possible? You can also try to remove the current drivers and after restarting computer windows could install the default drivers. You can check if that also works, too. If it doesn't, better to call support line.

http://www.krasotaiskusstva.com

Check out current deals!


Shop current deals

Top Kudoed Authors