Showing results for 
Search instead for 
Did you mean: 
Fanfold Paper
Posts: 3
Registered: ‎02-06-2015
Location: US
Views: 600
Message 1 of 4

USB issue with Y50-70


I have an issue recently with my y50-70 Model (80EJ59421863)

Since the plastic layer in my USB sockets got a bit torn. My laprop stopped sensing USB storage devices.It recognizes keyboard and mouse receivers and a limited set of USB storage devices.It still recognizes my old USB hardisks and flash , however , it does not recognize any other flash drives. Also it stopped recognizing my Mobile Phone completely.By not recognizing I mean that I insert the phone cable into any socket, then nothing happens at all.Just charging. That same phone with the same cable works on any other laptop.

Same problem still exist even after I replaced my USB port in some repair center.

I tried to use another versions of windows.I even tried Ubunto, uninstalled and reinstalled my USB drivers.Still same problem.

Now I think it is a hardware issue. So I am asking , should I replace my mother board? 
Do you have another suggestion? Is there some kind of hardware reset switch/jumper in the mother board that I can try resetting?

Can the problem be in some other hardware component than the mother board, before I buy a new one?


Your help is really appreciated

Paper Tape
Posts: 1
Registered: ‎10-28-2019
Location: US
Views: 585
Message 2 of 4

Re: USB issue with Y50-70

Fanfold Paper
Posts: 3
Registered: ‎02-06-2015
Location: US
Views: 574
Message 3 of 4

Re: USB issue with Y50-70

the reply appears empty, did you forget something or it is an issue with my browser ?

Oh... I got it, this is because you clicked "Have same question Smiley Happy". Hope somebody has an aswer to it.

Support Specialist
Posts: 625
Registered: ‎11-04-2019
Location: US
Views: 262
Message 4 of 4

Re: USB issue with Y50-70


Welcome to the Community Forums @ahmedshaabans! Nice to have you here.


Sorry for the delayed response, just joined here recently and noticed your post.


Try to perform these steps:


  • Boot into the BIOS by tapping F2 on startup then hit F9 to load default settings then press F10 to save and exit (this reloads the hardware configuration of the machine).
  • Insert the USB device (phone or mouse) into the USB 3.0 port but don't completely plug it in (leave about 1-2mm before it fully contacts the port) OR
  • Move the USB device slightly side ways and observe if the connection is stable.

Should the steps above fixes the problem then there's likely a problem with the USB 3.0 port and I recommend to contact the Lenovo helpdesk to report the issue for repair request as this may seem to be a possible hardware failure.


You can also try uninstalling USB 3.0 eXtensible Host Controller from Device Manager to refresh the port.


Or try these steps if the port fails to respond completely:


  • From an OFF state, press the Novo button to boot into the Recovery Environment. From here, try to test the USB mouse and observe.
  • You (Or) can also hold the Shift key while clicking Restart to boot into the Advanced Options and try the USB mouse there

Both of the above steps uses a native USB driver and this will isolate the problem on the OS level.


Update us on how it will go through, will be awaiting for your response.




Did someone help you today? Press the star on the left to thank them with a Kudo!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"! This will help the rest of the Community with similar issues identify the verified solution and benefit from it.

Follow us @LenovoSupport on Facebook and Twitter!

And we're back...

Move delayed but still coming

Learn More

Check out current deals!

Shop current deals

Top Kudoed Authors