English Community

Lenovo NotebooksLenovo P, Y and Z series Notebooks
All Forum Topics
Options

4 Posts

08-25-2011

USA (GA)

10 Signins

65 Page Views

  • Posts: 4
  • Registered: ‎08-25-2011
  • Location: USA (GA)
  • Views: 65
  • Message 1 of 6

Win7 forgets wireless passwords when set to auto-connect

2011-08-25, 20:52 PM

Title pretty much says it.  Check sig for specs/disclaimer. :P

 

 

I've never had problems with a wireless connection until about a week ago.  I constantly have to retype the password for all the connections I used to automatically connect to.  This is especially annoying for my campus network, since all the suggested solutions on other forums require going into router settings... Something I can't do.

 

Additional symptoms:

 

"Manage Wireless Connctions" always shows empty, even when connected to a wireless network.(Never used it before this issue started, not sure if it ever said anything.)

 

Can't add a network manually, says "access denied".

 

I heard of a solution using the Credential Manager, but I don't understand how it would work.  No credentials are loaded for me to delete and reinstall.

 

 

I've read tons of posts from people with the same problem, but they never get a solution that actually works and usually end up reinstalling Windows.  Reinstall is not an option for me.

Solved! See the solution
IdeaPad Z565 (4311)
Win7 x64 Home Premium
.
I AM NOT A NEWB! DON'T WASTE MY TIME WITH "HAVE YOU TRIED REBOOTING?" If I'm posting here I've already done the obvious solutions (reboot, update, search for previous solutions on this/other forums). I have a degree in IT, so don't be afraid to get complicated in your answers.
Reply
Options

2 Posts

08-25-2011

US

31 Signins

42 Page Views

  • Posts: 2
  • Registered: ‎08-25-2011
  • Location: US
  • Views: 42
  • Message 2 of 6

Re: Win7 forgets wireless passwords when set to auto-connect

2011-08-25, 23:55 PM

I had this exact problem back when I first had windows 7.  I wish I remembered all the details of the fix but I do know that the permissions on one of the system folders were the root cause of the issue.  I had to download a utility that would let me take ownership of the folder and rewrite the permissions to it - then it was able to store wireless networks and their login information again.  The access denied message you get is the tipoff - it can't write those settings to that particular system folder.  Again, I'm sorry I don't remember the specifics but that should get you going in the right direction.

Reply
Options

2 Posts

08-25-2011

US

31 Signins

42 Page Views

  • Posts: 2
  • Registered: ‎08-25-2011
  • Location: US
  • Views: 42
  • Message 3 of 6

Re: Win7 forgets wireless passwords when set to auto-connect

2011-08-25, 23:58 PM

From another forum:

 

Yep, giving 'Everyone' full control of the Wlansvc folder fixed this for me.

Reply
Options

4 Posts

08-25-2011

USA (GA)

10 Signins

65 Page Views

  • Posts: 4
  • Registered: ‎08-25-2011
  • Location: USA (GA)
  • Views: 65
  • Message 4 of 6

Re: Win7 forgets wireless passwords when set to auto-connect

2011-08-26, 17:31 PM

Well, I couldn't find a "wlansvc" folder, but I found the DLL in "system32".  I gave SYSTEM, LOCAL SERVICE, and  my user full control of the folder and file.

 

I don't like adding Everyone permissions to system files.  In the remote chance someone actually gets past my firewall, I don't want to leave myself open for chaos.

 

 

 

 I rebooted and nothing changed other than the amount of time it thinks it's trying to connect before it remembers that it forgot the passwords. :P

 

Any other solutions?  Or more specific instructions on this one?

IdeaPad Z565 (4311)
Win7 x64 Home Premium
.
I AM NOT A NEWB! DON'T WASTE MY TIME WITH "HAVE YOU TRIED REBOOTING?" If I'm posting here I've already done the obvious solutions (reboot, update, search for previous solutions on this/other forums). I have a degree in IT, so don't be afraid to get complicated in your answers.
Reply
Options

4 Posts

08-25-2011

USA (GA)

10 Signins

65 Page Views

  • Posts: 4
  • Registered: ‎08-25-2011
  • Location: USA (GA)
  • Views: 65
  • Message 5 of 6

Problem Solved

2011-08-26, 20:01 PM

Okay, I finally got it.  Thanks to wharfrat70 for pointing me in the right direction. :robotvery-happy:

My earlier search for the "wlansvc" folder came up empty because it's a hidden system folder.  The new Win7 search doesn't look for those.  But I did some google-ing for 'win7 "manage wireless connections" "access denied"' and found a forum on the first page with the full path of the folder.

Here's what I had to do:

Change security on the following folder (all folders above this one still had proper security settings, not sure why the "Interfaces" security changed):

C:\ProgramData\Microsoft\Wlansvc\Profiles\Interfaces

Read & execute, List contents, and Read
for Everyone, Users, and Administrators

Full Control
to my user, SYSTEM, and LOCAL SERVICE

 

 

(I did some editing for easier readability, so the the next person to have this problem and read this post will have an easier job.)

IdeaPad Z565 (4311)
Win7 x64 Home Premium
.
I AM NOT A NEWB! DON'T WASTE MY TIME WITH "HAVE YOU TRIED REBOOTING?" If I'm posting here I've already done the obvious solutions (reboot, update, search for previous solutions on this/other forums). I have a degree in IT, so don't be afraid to get complicated in your answers.

0 person found this solution to be helpful.

This helped me too

Reply
Options

1 Posts

07-23-2018

PK

1 Signins

20 Page Views

  • Posts: 1
  • Registered: ‎07-23-2018
  • Location: PK
  • Views: 20
  • Message 6 of 6

Re: Problem Solved

2018-07-23, 11:31 AM

Great!!! It also worked for me. Many thanks

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete