cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
daeven
What's DOS?
Posts: 1
Registered: ‎03-16-2015
Location: United States
Views: 199
Message 1 of 2

Y400 No Video

The on-board video on my Y400 has stopped working, but I do get video from an external monitor.  It started intermittantly, and I assumed it was due to damage from the left hing failure.  I replaced the hinges and the LCD cable and thought all was better, but the LCD became intermittant again, and now never works.  It looks like I have backlight.

 

I've heard that inverter failures are common with LCD problems, but can't find a replacement inverter anywhere.  Is the inverter just for backlighting?

Social Support Agent
Social Support Agent
Posts: 5,822
Registered: ‎02-11-2012
Location: PH
Views: 185
Message 2 of 2

Re: Y400 No Video

hi daeven,

 

Welcome to the Forums.

 

From your description, it does seem like you have a failing LCD panel. Upon looking at page 84 of the hardware maintenance manual, the Y400 uses a LED type panel (unlike the older CCFL, these LED screens doesn't have an inverter board that controls the backlight).

  - Link to picture

 

From the looks of it, you may need to replace the entire screen.

  - Sample item

 

Y400 Video DIsassembly (see FRU Videos)

 

 

Regards



Did someone help you today? Press the star on the left to thank them with a Kudo!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"! This will help the rest of the Community with similar issues identify the verified solution and benefit from it.

Follow us @LenovoSupport on Facebook and Twitter!

Check out current deals!


Shop current deals

Top Kudoed Authors