cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
jd21
Blue Screen Again
Posts: 19
Registered: ‎12-05-2012
Location: India
Views: 777
Message 1 of 5

Y480 - USB Ports, WebCam and Bluetooth not working. please help very urgent.

two days before i got a weird message from one of a usb 3.0 port(left first) "Power Surge on Hub Port" "USB device has exceeded the power limits of its hub port" by clicking on that message a window opened to reset all the usb ports to work properly. after resetting and restart all of my usb ports failed to work. to my surprise bluetooth and webcam also failed. not even detect in device manager.

 

tried so many many possible solutions from google to solve the issue. tried a fresh install win 7 and onekey recovery factory restore. updated BIOS also. nothing helped.

 

uninstalled and reinstalled the usb drivers too many times. now getting a message "USB Device Not Recognized" all the time the pc is on though usb peripherals are connected or not connected. always i can hear a connect and disconnect windows sound even if no devices are connected.

 

after numerous restarts one of a usb 3.0(left, near hdmi) starts to work. but, it won't detect the device immediately after connecting. if all the usb drivers uninstalled and reinstalled then the usb port started to work showing the connected device. other three usb ports no response. after some restarts second port(right, near mic jack) starts to work same as first. other two still no response. if disconnect the device from any one of the two ports then again have to uninstall and reinstall the drivers to device work.

 

but, all the ports getting power to them. if i connect my mobilephone to all ports the phone gets power to charge. wonder how it's possible. all of my usb ports still alive?.

 

now i can't boot from a flash drive or hdd from any one of these ports. coz, the devices are not shown in the BIOS as well as in the boot menu(F12). before i can boot from usb and see the connected device in BIOS. if i power on my laptop with any devices connected in these two partially working usb 3.0 ports windows can easily detect and devices are shown in MY COMPUTER.

 

still i can't find a solution and don't know what's a root cause?.

 

bluetooth and webcam not even detect/shown in the device manager. device drivers are installed and it can be seen in the hidden devices list. Lenovo YouCam can't detect the webcam and skype also.

 

now after a cold start to my surprise bluetooth starts to work and my bluetooth mouse paired & working. oops, worked for few minutes and bluetooth disappeared. connecting and disconnecting.......... continues with "USB Device Not Recognized".

 

still webcam not detected.

 

please help me to find out a solution to my problems. whether it's a hardware or software issue?.

am in out of warranty so suggest me a better way and help to work my laptop normally.

jd21
Blue Screen Again
Posts: 19
Registered: ‎12-05-2012
Location: India
Views: 754
Message 2 of 5

Re: Y480 - USB Ports, WebCam and Bluetooth not working. please help very urgent.

any help??????????????????????
jd21
Blue Screen Again
Posts: 19
Registered: ‎12-05-2012
Location: India
Views: 737
Message 3 of 5

Re: Y480 - USB Ports, WebCam and Bluetooth not working. please help very urgent.

nobody has no idea about my problems. any help will be appreciated.
jd21
Blue Screen Again
Posts: 19
Registered: ‎12-05-2012
Location: India
Views: 721
Message 4 of 5

Re: Y480 - USB Ports, WebCam and Bluetooth not working. please help very urgent.

bump.

jd21
Blue Screen Again
Posts: 19
Registered: ‎12-05-2012
Location: India
Views: 669
Message 5 of 5

Re: Y480 - USB Ports, WebCam and Bluetooth not working. please help very urgent.

now, my ideapad is dead. if power/onekey recovery button is pressed led is on in the power button, fan spins, HDD heats up but, no display and nothing happens after that. 

 

any ideas will be appreciated.

Check out current deals!


Shop current deals

Top Kudoed Authors