Showing results for 
Search instead for 
Did you mean: 
Punch Card
Posts: 14
Location: DE
Message 11 of 80

Re: Y50 70 BIOS Can't Save Settings Or Exit

Me too!

This is totally weird. I cannot change anything but the time and date. None of the method found on internet worked.

I've Linux installed so even flashing BIOS is not an option.

I've tried to install complete new system on a second harddrive, swap it after but BIOS is failing to boot.


Lenovo support, you are really needed here!

Punch Card
Posts: 14
Location: DE
Message 12 of 80

Re: Y50 70 BIOS Can't Save Settings Or Exit

I've found an advice to remove cmos battery, main battery and memory and do several restarts combined with adding the cmos, memory etc. every few reboot sequentially.

It didn't work.

I'm still stucked with same configuration. Lenovo phone support said without Windows I/they cannot do nothing. Only sending the laptop for (after warranty) service. We will see, how much that will put me back...

Paper Tape
Posts: 6
Location: ZA
Message 13 of 80

Re: Y50 70 BIOS Can't Save Settings Or Exit

I am having the same problem. Any new updates ???
Fanfold Paper
Posts: 3
Location: NL
Message 14 of 80

Re: Y50 70 BIOS Can't Save Settings Or Exit

same here

Punch Card
Posts: 14
Location: DE
Message 15 of 80

Re: Y50 70 BIOS Can't Save Settings Or Exit

OK, although the problem is marked as "Solved" it is not.



I'm a Linux user and tested this solution only with Linux. It has very big chance to work with Windows, but I cannot tell, if this would work without extra effort.

I've created a "prosthetic" bypass allowing me to avoid Lenovo service and (most probably) very expensive option of replacing MB.

To the point.


I had working Antergos installation while discovered the BIOS issue. Wanted to install new system but was not allowed to change boot settings (nor in BIOS or via boot menu).

Using command:


efibootmgr -v

I've got my EFI boot configuration that looks like this:



BootCurrent: 0001
Timeout: 0 seconds
BootOrder: 0001,0002,2001,2002,2003
Boot0001* antergos_grub HD(1,GPT,f128f12b-fa3e-45b1-b5c9-f03c328498cb,0x800,0x64000)/File(\EFI\antergos_grub\grubx64.efi)
Boot0002* Windows Boot Manager  HD(1,GPT,f128f12b-fa3e-45b1-b5c9-f03c328498cb,0x800,0x64000)/File(\EFI\Microsoft\Boot\bootmgfw.efi)RC
Boot2001* EFI USB Device        RC
Boot2003* EFI Network   RC

It means the file grubx64.efi in antergos_grub directory will be loaded as first. Nothing else. And from no other drive but the 1st having the ID: f128f12b-fa3e-45b1-b5c9-f03c328498cb


So. Am I forever bound the Antergos? Well, no.

Long story short.

I've downloaded rEFInd package and REPLACED the antergos_grub directory with the content of rEFInd package, renaming the refind_x64.efi to grubx64.efi
Now, after restart I've rEFInd boot menu (you can compare it to the BIOS boot menu) with the option for selecting boot source (including USB drives and optical drive (my case also via USB)).

This way I was able to install openSUSE and few other systems in between.


You must never erase the first partition with the rEFInd bootloader.

It will bind automatically systems installed on the next boot partition.


What if my hard drive got damaged or anything... Well, I thought of that too.

Using command:

sfdisk -d /dev/sda > HD_partitions.txt

you get a file named HD_partitions.txt containing IDs of all your partitions.

You only need the first value. In my case:

/dev/sda1 : start=        2048, size=      409600, type=C12A7328-F81F-11D2-BA4B-00A0C93EC93B, uuid=F128F12B-FA3E-45B1-B5C9-F03C328498CB, name="EFI System Partition"

I took second disc, made same first partition on it, exported the partition table with the same command and REPLACED the uuid value from the main disc.

Then what you need to do is flipping the "pipe" direction, from ">" to "<" and write the partition table to another disc:

sfdisk -d /dev/sdb < modified_partition_table.txt

(Assuming the second drive is sdb!!!).

That is all.


rEFInd is your friend.


Thank you for your attention.


Paper Tape
Posts: 4
Location: US
Message 16 of 80

Re: Y50 70 BIOS Can't Save Settings Or Exit

Thank you. I made Ubuntu as Bootloader for refind as it's the first efi config to boot.

But How you could install other linux distros while they need grub, and the installer can't access EFI to install GRUB because it thinks it's in legacy mode?
Punch Card
Posts: 14
Location: DE
Message 17 of 80

Re: Y50 70 BIOS Can't Save Settings Or Exit

To install further Linux(es) you need to create second EFI partition where the GRUB is installed. rEFInd will detect all of them and show in the menu to select from. This is how I have it right now.

What's DOS?
Posts: 1
Location: GB
Message 18 of 80

Re: Y50 70 BIOS Can't Save Settings Or Exit

@Marcin78 (post 15) You are the best!! I've been stuck having to press f12 and choose the windows bootloader because an old ubuntu bootloader was default for a year now...


Worked like a charm (on my y70-70 Touch) =] I just had to get all the files from the old ubuntu bootloader that I had deleted (duh!) and then put refind on top and now I can usb boot again!


Thank you for giving me back my linux!

Punch Card
Posts: 14
Location: DE
Message 19 of 80

Re: Y50 70 BIOS Can't Save Settings Or Exit

Glad to hear at least one successful story!
I really wonder, how much would Lenovo charge for reparation.

Hope someone will report here.
Paper Tape
Posts: 8
Location: IT
Message 20 of 80

Re: Y50 70 BIOS Can't Save Settings Or Exit

I have the same problem... after upgraded Ubuntu to 17.10 version, the bios won't save any change... 

So, i bought a new chip and a will try to flash with an older version of my bios...

Stay tuned!

Top Kudoed Authors