cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Shaleghi
Paper Tape
Posts: 6
Registered: ‎10-20-2017
Location: ZA
Views: 2,737
Message 1 of 5

Y50-70 BIOS Can't Save Settings or boot with USB

The problem is very similar than this link but I want to repost since it is not solved. 

 

https://forums.lenovo.com/t5/forums/v3_1/forumtopicpage/board-id/ll04_en/page/1/thread-id/154203

 

I removed the battery and bios battery. Then pressed the power button..  Bios settings stay the same and I still cannot change them. 

 

Changing the platform.ini is not an option because I have ubuntu installed. I can not install windows because USB boot is not working.  I think the Bios and USB boot problems is linked.

 

Any help will be much appreciated !?

 

IMAGE REMOVED

 

IMG_2602.JPGIMG_2601.JPG

 

Mod's Edit:  Image removed for member's protection as it showed the serial number of the laptop.  Please edit out the serial number information if you wish to repost the image.  Thanks!

 

amrturk
Fanfold Paper
Posts: 8
Registered: ‎08-12-2015
Location: EG
Views: 2,660
Message 2 of 5

Re: Y50-70 BIOS Can't Save Settings or boot with USB

i have the same problem and it also appear after install ubuntu mate 17.10

 

Andy90
Fanfold Paper
Posts: 3
Registered: ‎10-23-2017
Location: NL
Views: 2,650
Message 3 of 5

Re: Y50-70 BIOS Can't Save Settings or boot with USB

I have the same issues, this has been reposted in 3 threads. The solution where you change the check_version flat in platform.ini doesn't actually work, even on windows. The system will simply reboot and nothing will happen. I think this is because by default downgrading is disabled in the bios and it can't be saved.

amrturk
Fanfold Paper
Posts: 8
Registered: ‎08-12-2015
Location: EG
Views: 1,336
Message 4 of 5

Re: Y50-70 BIOS Can't Save Settings or boot with USB

hi all i have solve my problem on my lenovo y50-70 by this post

https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1734147

 

by use this instruction in the post

Fix: The issue was fixed in kernel version 4.13.0-21 by configuring the kernel so it is not compiled with Intel SPI support. But previous affected machines still suffered from a broken BIOS.

Repair: If you still can boot into Ubuntu, you can recover your BIOS with the following steps:

1. Boot into Ubuntu
2. Download http://people.canonical.com/~ypwong/lp1734147/linux-image-4.15.0-041500rc6-generic_4.15.0-041500rc6....
3. Install the downloaded package:
  $ sudo dpkg -i linux-image-4.15.0-041500rc6-generic_4.15.0-041500rc6.201712312330+20170103+1_amd64.deb
4. Make sure the kernel is installed without any error. Once installed, reboot.
5. At grub, choose the newly installed kernel. You can choose the "recovery" mode.
6. Reboot and go to BIOS settings to confirm your BIOS has been recovered.
7. In case your BIOS is not recovered, reboot to the new kernel, then reboot *once again* to the new kernel, do not enter BIOS settings before the reboot. After the second reboot, check BIOS.
8. If your BIOS issue remains, download another kernel from http://people.canonical.com/~ypwong/lp1734147/linux-image-4.15.0-041500rc6-generic_4.15.0-041500rc6...., and use dpkg to install it, then repeat steps 4 to 6.

After your BIOS is fixed, the kernel packages you just installed are no longer needed, you can remove it by running 'sudo dpkg -r linux-image-4.15.0-041500rc6-generic'.

The patch used to build the linux v4.15 kernel in step 8 can be found at https://goo.gl/xUKJFR.

---

Test Case: Fix has been verified by our HWE team on affected hardware.

Regression Potential: Minimal, it's unlikely anyone is actually doing anything which requires this driver.

DarkShadowYP
Paper Tape
Posts: 2
Registered: ‎12-09-2015
Location: IN
Views: 1,154
Message 5 of 5

Re: Y50-70 BIOS Can't Save Settings or boot with USB

Thanks for the help.

Now it works for updating the BIOS.

 

Now I am facing the problems in windows (Dual Boot with Ubuntu latest and Windows 10).

It shows the error while booting Windows as follows.

 

alloc magic is broken at 0x74cc3de0: 0

Aborted. Press any key to exit.

 

Please check it and inform if any solutionerror.jpeg

 

Check out current deals!


Shop current deals

Top Kudoed Authors